Install FreeBSD 12.1 KVM AARCH64

Hi all,

I am trying to install FreeBSD 12.1 on a virtual machine, I have downloaded the FreeBSD-12.1-RELEASE-arm64-aarch64-memstick.img image installer, however, after booting the kernel it fails with the following message:

Mounting from ufs:/dev/ufs/FreeBSD_Install failed with error 19.

Loader variables:

Manual root filesystem specification:
  <fstype>:<device> [options]
      Mount <device> using filesystem <fstype>
      and with the specified (optional) option list.

    eg. ufs:/dev/da0s1a
        cd9660:/dev/cd0 ro
          (which is equivalent to: mount -t cd9660 -o ro /dev/cd0 /)

  ?               List valid disk boot devices
  .               Yield 1 second (for background tasks)
  <empty line>    Abort manual input


The installer image is on a USB controller, but also I have tried by using SCSI, SATA and VirtIO controllers. The error is always the same.

The host machine is a Raspberry PI 4 running Ubuntu 20.04LTS, and it is having other VMs running perfectly (Fedora server and a Debian one).

Any configuration that should make the FreeBSD installer to start so I can install FreeBSD on that VM?

Many thanks for any help!
A few things. First, please fix the thread title ... I had to look twice to figure out what the 65-bit architecture is. That's just to make your question easier for others.

Second, the raspberry Pi is a second-tier platform for FreeBSD. It sorta-kinda works, but not great. Look at the discussions in the forum section that's dedicated to "other" architectures (non-x86) and to embedded platforms. In particular, the Pi4 version still has significant issues, which are discussed there. You might want to ask there.

Third, running VMs on a Pi and then different OSes in those VMs is probably one step over the edge of what is commonly done. Honestly, I'm not surprised that things break.

And just to be clear: I have nothing against Pi's. I own quite a few of them, and have two running in production (to be honest, the second one is back on the lab bench in pieces, to get the hardware upgraded, but it will be in production if I find some free evenings to do soldering). But we all need to understand that the effort to make FreeBSD run on the Pi is not staffed at the level of it being plug-and-play.
Thanks for your answer.

I have changed the thread to AARCH64, sorry about the mistake.

On the other hand, I know it is 2nd tier, but as you said, I will review the "other" architectures section, thats a goot tip.

If I have the time to investigate and solve, will share it.
Any configuration that should make the FreeBSD installer to start so I can install FreeBSD on that VM?

If I remember well, there is no installer for SBC, what you download is a disk image to be burnt on a SD card, so you might want to use it directly as a raw image for QEMU.
Hey corrosion, did you ever get this to work? I have a spare Raspberry Pi 4B laying around with 4GB of RAM and want to make a few KVM virtual machines on it, including a FreeBSD one. Can you share your experiences?
Hi tommiie, unfortunately, I have yet not been able to make FreeBSD to properly boot under KVM on the raspberry pi, not even FreeBSD 13, the behavior is the same.
If you want to run FreeBSD in a VM on a RPi, let me suggest that this might be the easiest way to get there: Boot the standard Debian-based distribution that's fully supported by the Raspberry Pi foundation. It used to be called "Raspbian", but there may have been name changes recently. I run it on a handful of RPi's at home, and have zero problems. It works flawlessly (including WiFi), and once you learn how to deal with Linux, administering it is easy and painless. Once you have that, you should be able to create VMs on it, and run FreeBSD in those, without having to do the fight to get the hardware support on the RPi to work in FreeBSD.