Solved includes /compat/linux/include

In the moment I am trying to port workbench63 and update net-p2p/retroshare. In both cases I have the problem, it does not find the includes (header-files) from /compat/linux/include. The files are there. I have tried to add it to $PATH, tried CONFIGURE_ENV, MAKE_ENV, -I/compat/linux/include without success. (workbench63 work with cmake, net-p2p/retroschare with qmake). Any hint? Or what have I overlooked?
Why do you want to use the Linux includes? As far as I know we don't even have a Linux cross-compiler in the ports so I don't see how you could even make use of the Linux includes in porting. All of the Linux ports that I've seen are not built on FreeBSD using compilers but they just make use of pre-built binaries from the official RPMs.
In the case workbench63 it searches the sys/prctl.h and sys/features.h files (prctl.h includes features.h). The only prctl.h I could find is in /compat/linux/includes.
Maybe the problem with net-p2p/retroshare is a complete other.
You need to fix those Linuxisms by converting the code to use FreeBSD's own APIs, that's how many of the ports have been ported from Linux to FreeBSD.