in_cksum_skip: out of data by 40290 ...

gorec2005

New Member


Messages: 7

Hi ALL!
in syslog is - :

Code:
...
in_cksum_skip: out of data by 40290
in_cksum_skip: out of data by 23970
in_cksum_skip: out of data by 15810
in_cksum_skip: out of data by 15810
in_cksum_skip: out of data by 15810
in_cksum_skip: out of data by 10200
in_cksum_skip: out of data by 10200
in_cksum_skip: out of data by 10200
in_cksum_skip: out of data by 47685
in_cksum_skip: out of data by 32385
in_cksum_skip: out of data by 32385
in_cksum_skip: out of data by 32385
in_cksum_skip: out of data by 61455
in_cksum_skip: out of data by 23205
in_cksum_skip: out of data by 10200
in_cksum_skip: out of data by 16830
in_cksum_skip: out of data by 27285
in_cksum_skip: out of data by 37740
...

Is this normal? And if not - where the search cause of the problem?
 

Savagedlight

Well-Known Member

Reaction score: 100
Messages: 369

No, this is not normal.
Can you post some more details on your network cards?

Some chips say they support hardware checksumming, but in reality do a poor job at it (as you can see in your log). This might be either a hardware or a driver issue.

To disable hardware checksumming:
# ifconfig interface -TXCSUM -RXCSUM -VLAN_HWCSUM
If this helps, you'd want to add those options to your interface configuration in /etc/rc.conf in order to make them permanent.
 

yongari@

Member
Developer

Reaction score: 28
Messages: 76

Because the length is too big for normal mbuf, I guess it was caused by missing host byte order conversion before doing checksum computation.
Are you using pf/ipfw/ipf?
 
OP
gorec2005

gorec2005

New Member


Messages: 7

Savagedlight said:
No, this is not normal.
Can you post some more details on your network cards?
I use vmware esxi 4.1 freebsd FreeBSD 8.1 (cvs updated as guest os and netcard in esxi intel (em driver)
Savagedlight said:
Some chips say they support hardware checksumming, but in reality do a poor job at it (as you can see in your log). This might be either a hardware or a driver issue.

To disable hardware checksumming:
# ifconfig interface -TXCSUM -RXCSUM -VLAN_HWCSUM
If this helps, you'd want to add those options to your interface configuration in /etc/rc.conf in order to make them permanent.

I tried, but the situation has not changed :-(
 
OP
gorec2005

gorec2005

New Member


Messages: 7

yongari@ said:
Are you using pf/ipfw/ipf?
yes Yes - i I use mpd5 as pppoe server + radiusd + ipfw (for nat).
i I tried embedded em driver, em driver from intel site, em driver from yandex, but w/o without success..
 
Top