I'm back and I'm not happy (Clang not GCC)

Greg Quinlan

New Member

Reaction score: 4
Messages: 13

Hi All

I have been away for a little while. (since about 1998 on the forums)

I recently installed FreeBSD 10.1 (as a VMWare 11.1 VM), tried to get a version of FreeBSD-arm (yes I am impatient) for a Raspberry PI 2 working from various source components. (a more recent u-boot-rpi, crochet modified, latest RPI boot files.. etc)

When I tried to piece it all together, I noticed that cortex-a7 CPU was unknown... WHAT? ( I am sure GCC supported it)

Then I noticed some strange fatal compiler errors - which is very strange for gcc, then I discovered Clang!!! (which does not support some arm CPUs)
Code:
FreeBSD clang version 3.4.1 (tags/RELEASE_34/dot1-final 208032) 20140512
Target: x86_64-unknown-freebsd10.1
Thread model: posix
NOT A PROBLEM... I will install GCC from lang/gcc48 (or pkg install gcc48)

Got the following from clang..
Code:
.... -Wwrite-strings -Wcast-qual -Wmissing-format-attribute -pedantic -Wno-long-long -Wno-variadic-macros -Wno-overlength-strings  -DHAVE_CONFIG_H -I. -I. -I.././../gcc-4.8-20150212/gcc -I.././../gcc-4.8-20150212/gcc/. -I.././../gcc-4.8-20150212/gcc/../include -I.././../gcc-4.8-20150212/gcc/../libcpp/include -I/usr/local/include  -I.././../gcc-4.8-20150212/gcc/../libdecnumber -I.././../gcc-4.8-20150212/gcc/../libdecnumber/dpd -I../libdecnumber -I.././../gcc-4.8-20150212/gcc/../libbacktrace  -DLIBICONV_PLUG .././../gcc-4.8-20150212/gcc/alias.c -o alias.o
.././../gcc-4.8-20150212/gcc/alias.c: In function 'alias_set_type new_alias_set()':
.././../gcc-4.8-20150212/gcc/alias.c:835:1: internal compiler error: Segmentation fault
 }
 ^
no stack trace because unwind library not available
Please submit a full bug report,
with preprocessed source if appropriate.
See <[URL]http://gcc.gnu.org/bugs.html>[/URL] for instructions.
Makefile:1059: recipe for target 'alias.o' failed
gmake[5]: *** [alias.o] Error 1
gmake[5]: *** Waiting for unfinished jobs....
rm gcj-dbtool.pod jcf-dump.pod jv-convert.pod grmic.pod gcj.pod gc-analyze.pod gcov.pod gfortran.pod gfdl.pod gij.pod gcc.pod cpp.pod fsf-funding.pod
gmake[5]: Leaving directory '/usr/ports/lang/gcc48/work/build/gcc'
Makefile:4194: recipe for target 'all-stage2-gcc' failed
gmake[4]: *** [all-stage2-gcc] Error 2
gmake[4]: Leaving directory '/usr/ports/lang/gcc48/work/build'
Makefile:20164: recipe for target 'stage2-bubble' failed
gmake[3]: *** [stage2-bubble] Error 2
gmake[3]: Leaving directory '/usr/ports/lang/gcc48/work/build'
Makefile:20370: recipe for target 'bootstrap-lean' failed
gmake[2]: *** [bootstrap-lean] Error 2
gmake[2]: Leaving directory '/usr/ports/lang/gcc48/work/build'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/lang/gcc48
*** Error code 1

Stop.
make: stopped in /usr/ports/lang/gcc48
Wooh!!

Any comments?
 

Oko

Daemon

Reaction score: 771
Messages: 1,620

Raspberry Pi is closed hardware requiring tons of firmware. Never understood why NetBSD and FreeBSD bothered.
 
Top