ILO text console working in graphic mode

gulli

New Member


Messages: 10

Hello,

I am quit new in freebsd administration and have a problem with ILO text console. It looks like the graphic mode is ON.

It is showing: "Monitor Is in Graphics Mode or an Unsupported Text Mode" and some colored words.

Any idea to switch off and make text console readeble please?

Thanks.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 13,978
Messages: 40,708

Add to /boot/loader.conf:
Code:
hw.vga.textmode=1
I found this to work better with IPMI remote consoles, especially the older IPMI versions. It just looks better and the console window is resized properly.

Code:
     hw.vga.textmode
             Set to 1 to use virtual terminals in text mode instead of
             graphics mode.  Features that require graphics mode, like
             loadable fonts, will be disabled.
From vt(4).
 
OP
G

gulli

New Member


Messages: 10

Add to /boot/loader.conf:
Code:
hw.vga.textmode=1
I found this to work better with IPMI remote consoles, especially the older IPMI versions. It just looks better and the console window is resized properly.

Code:
     hw.vga.textmode
             Set to 1 to use virtual terminals in text mode instead of
             graphics mode.  Features that require graphics mode, like
             loadable fonts, will be disabled.
From vt(4).

Hi SirDice,

thanks a lot, it is working properly!

Gulli
 

neel

Active Member
Developer

Reaction score: 68
Messages: 147

this trick doesn't seem to work with ILO5 :/
Are you using UEFI or BIOS mode? On a HPE ProLiant ML110 Gen10, I can use FreeBSD 12.x and 13.x fine with iLO5 on a UEFI framebuffer console.

I can't speak for other HPE servers (e.g. DL380, Microserver, etc.).

IMHO switch to UEFI mode, just make sure Secure Boot is disabled.
 
Top