Solved ifconfig scan does not list my ssid

osvaldo

New Member


Messages: 6

Hello all,
I am pretty new with FreeBSD (13.0), I have a problem with wifi at home, at office it works fine.
Yesterday I had to restart my home router and after that, the command:

ifconfig wlan0 list scan

does not list my SSID anymore, so the laptop does not connect to internet.
An android phone and the other NetBSD laptop do.
In the scan list, only my SSID is missing.

Thanks in advance.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,735
Messages: 39,332

Do you have a so-called "hidden" SSID?
 
OP
O

osvaldo

New Member


Messages: 6

I do not know, I will read up on this thing, but there are two strange things:
-before restarting the modem the wifi worked on freebsd.
-the latop with netbsd and the andoid phone are still working.
Thanks.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,735
Messages: 39,332

What wifi card do you have? What driver is it using?
 

George

Aspiring Daemon

Reaction score: 212
Messages: 520

I use "up", e.g. ifconfig wlan0 up scan. I feel like this has a higher chance of showing all ssids. Maybe because it causes a new scan, dunno.

The man file writes that for long ssids, scan needs the "-v" flag.
 
OP
O

osvaldo

New Member


Messages: 6

Attachments

  • kldstat.txt
    1.2 KB · Views: 22
  • rc.conf
    389 bytes · Views: 21
  • wpa_supplicant.conf
    308 bytes · Views: 20
OP
O

osvaldo

New Member


Messages: 6

I use "up", e.g. ifconfig wlan0 up scan. I feel like this has a higher chance of showing all ssids. Maybe because it causes a new scan, dunno.

The man file writes that for long ssids, scan needs the "-v" flag.
my ssid is -kamakiriad- a scan from netbsd laptop shows it, while missing in Freebsd,
an "up" scan shows me less ssids then a "list" scan
the -verbose flag does not show me new ssids.
 

Attachments

  • scanNetbsd.txt
    652 bytes · Views: 16
  • scan_list_Freebsd.txt
    483 bytes · Views: 17
  • scan_up_Freebsd.txt
    487 bytes · Views: 16

CuatroTorres

Member

Reaction score: 39
Messages: 85

Sorry but I don't know what you are on about. I noticed that the channel is #12 and after the restart the router may have changed it.

Bsdinstaller asked you for your wifi domain/country or you pressed Skip. You may have set the wrong zone and your auto channel on the router is out of the allowed range.
Manually put channel #1 on your router temporarily, if it shows the SSID on the scan, change the regdomain setting on your FreeBSD box, as shown in the manual (32.3.3.2. Setting the Correct Region).

 
Top