IBM T30 laptop interrupt storms

viesic

New Member

Reaction score: 1
Messages: 4

I have an IBM T30 2366 laptop, with Atheros AR5006 (5212 chip) mini pci card, running freebsd 7.1 RC1 with generic kernel and I`m having interrupt storms, when using this wireless card. If I enable this card "# ifconfig ath0 up" or connect to access point I'm having "kernel: interrupt storm detected on "irq9:"; throttling interrupt source" messages filling /var/log/messages log file. When this "storm" appears wireless connection is lost to Access Point. If I set hw.intr_storm_threshold value to much higer value (tried 10000 and 100000), it's not helping at all, i see much less those messages, but connection to Access Point is lost anyway, and PC freezes for some second approximately every five minutes.
I also tried fbsd 6.1, 6.3 and 7.0 and had the same problem. Tried NetBSD and winxp and got no problems with wireless at all. Tried to change IRQ for this card in bios, but got no improvements, those storms occupy that IRQ too. I think the problem is that ath0 is sharing an irq with uhci, but i can't set different irq's for these devices.
Tried to boot with acpi off - no improvements, tried to compile kernel without any usb and networking (except ath) devices - no improvements.
Also tried to recompile ACPI asl file, and got no errors or warning messages. Tried another pcmcia ral0 wireless card and got interrupt storms on irq 11, which is shared with pcmcia cardbus adapter and intel fxp0 device. ath0 driver is not supporting device polling, so i can`t test it.

here is some info about hardware:
verbose dmesg
pciconf -lv
vmstat -i (actually i don't see any "storm" there, maximum interrupt rate i have seen is ~ 16k, when uploading a very large file over network)
/var/log/messages

I have run out of ideas what to try else. :(
 
Top