Other i3wm does not launch the second time

antoyo

New Member


Messages: 5

Hello.
I am a beginner with FreeBSD (coming from ArchLinux) and I am having trouble to setup my desktop.
The first time I launch i3wm, it works, but the second time it does not run and I see the following error:

Code:
ERROR: No outputs found via RandR, disabling
xinit: connection to X server lost
I can launch i3wm again by deleting the ~/.i3/config file.

I use PCDM (I also tried slim).

Here is the content of my .xinitrc:

Code:
exec /usr/local/bin/i3
(not sure if it is used by PCDM, but it is by slim).

What can I do to be able to run i3 more than once?

Thanks for your help.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,113
Messages: 33,671

Not sure what the problem is but a good source to look for errors in this case is /var/log/Xorg.0.log. See if you can spot a difference between a good and a bad start.
 
OP
antoyo

antoyo

New Member


Messages: 5

Thanks for your answer.
I do not see any meaningful error message in this file.
And the only difference in the messages from stdin and stderr are related to i3 (i3status, pango, …).
By the way, I was able to fix the error shown in my first post (by using the xrandr command in .xinitrc but I still get the blank screen).

The only error I see now (in both cases) is:
Code:
failed to set mtrr: Invalid argument
I tried in DragonFlyBSD and I got the same issue.

By the way, I run FreeBSD in a virtual machine (qemu).
Do you think it could be different in a physical machine?

Thanks for your help.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,113
Messages: 33,671

The only error I see now (in both cases) is:
Code:
failed to set mtrr: Invalid argument
I tried in DragonFlyBSD and I got the same issue.
Yeah, I've seen that one on a couple of machines too. As far as I know you can safely ignore it.

By the way, I run FreeBSD in a virtual machine (qemu).
Do you think it could be different in a physical machine?
Definitely. I'm not sure how QEMU virtualizes the video hardware but the issue may be with that. Perhaps it's not freeing it properly which would give problems the next time you try to start it. You may want to try VirtualBox instead of QEMU if you want to keep using virtual machines. FreeBSD should run properly on that and also has the guest additions in the ports tree (emulators/virtualbox-ose-additions).
 
OP
antoyo

antoyo

New Member


Messages: 5

I have the same problem with VirtualBox (even with the guest additions).
The error about `mtrr` disappear though.
Thanks for your answer.
 

protocelt

Daemon

Reaction score: 413
Messages: 1,253

Does i3 start more than once when starting it from the console using startx(1) and just the ~/.xinitrc file? If it does then it could be an issue relating to the login manager.
 

tingo

Daemon

Reaction score: 489
Messages: 2,273

Are you using vt(4) or sc(4)? The "Xorg can only start once" used to be an issue when I was using the sc driver. Now, with vt, things work much better.
 
OP
antoyo

antoyo

New Member


Messages: 5

I've just tried with vt(4), but I get the same issue.
I'll try on a real computer soon.
Is it possible to create a bootable USB from the ISO?
I've tried with dd with the USB is not bootable.
 

protocelt

Daemon

Reaction score: 413
Messages: 1,253

I've just tried with vt(4), but I get the same issue.
I'll try on a real computer soon.
Is it possible to create a bootable USB from the ISO?
I've tried with dd with the USB is not bootable.
The ISO files only work with CD/DVD media. For booting from USB media, use the *-memstick.img file appropriate for your machine.
 

bp2626

New Member


Messages: 2

Looks to be an issue with the i3 package? I'm having the same problem and it does not occur with other window managers.
 

bp2626

New Member


Messages: 2

Not sure if you have the same problem, but also see Thread 55343.
I did notice the incomplete configuration file but I didn't really think anything of it. Using the stock configuration file and editing it, as mentioned in that thread did indeed fix the problem, thank you.

Here everything works well using startx(1). The only suggestion I have is to try the pure x11-wm/i3 without status bar and without a possible x11/dmenu.
After the package wasn't working I did indeed remove all the i3 related packages and build just i3 from ports and the problem persisted. The bug was that i3 was generating an incomplete/broken config file. It is either a bug with i3 or the port.
 

chrbr

Aspiring Daemon

Reaction score: 268
Messages: 714

The discussion https://github.com/i3/i3/issues/2199 might to be related, too. Please find below is the first post.
Code:
3 version 4.11 (2015-09-30, branch "4.11") © 2009 Michael Stapelberg and contributors
Logfile: http://logs.i3wm.org/logs/5639221461123072.bz2

With the default config and no terminal emulator, attempting to exit i3 with the exit
keybind raises i3-nagbar, and clicking "Yes, exit i3" raises an error "i3-sensible-terminal
could not find a terminal emulator. Please install one." Apparently i3-nagbar requires a
terminal emulator (https://github.com/i3/i3/blob/next/i3-nagbar/main.c#L178). Exiting
works, if the exit keybind in the config file is modified to simply do 'exec "i3-msg exit"' .
 

dch

Active Member

Reaction score: 50
Messages: 128

FWIW this bit me as well. There's 2 changes we could make:

- include a suitable terminal as a port dependency. urxvt seems like a nice choice but X is new to me
- don't include a dependency but update the message in the i3 package to give a list of suitable terminals
 

chrbr

Aspiring Daemon

Reaction score: 268
Messages: 714

- include a suitable terminal as a port dependency. urxvt seems like a nice choice but X is new to me
This could be done within the make configure mechanism. The user could select "xterm", "urxvt" or so. "nothing" should be an option, too. Just in case the user has a different preference.
- don't include a dependency but update the message in the i3 package to give a list of suitable terminals
This is something you can propose on i3 as a feature request.
 

bookwormep

Well-Known Member

Reaction score: 186
Messages: 322

I use x11-wm/i3 as a window manager. My ~/.xinitrc does not contain 'exec'.

The line is simply:
Code:
/usr/local/bin/i3
. I hope this might help. I do not use Slim at all.

I do not use PCDM. However, I use HAL for older hardware; and to start an X session I use:

Code:
$ startx
 
Top