I have a beginners question

George Daxon

Member


Messages: 21

Ok, I am sure you get a lot of these questions and I really appreciate your help. I have looked through the guide and I cannot get the mount command to work for me.

Currently, I am doing a test run on a spare computer for FreeBSD. I only have a single hard drive installed and the spare is a learning machine. Its not even connected to the internet yet. Just getting familiar with FreeBSD

I am trying to mount my DVD/CDROM. I have a copy of ntfs-3g on the cd that I downloaded from the website. I used a windows based system to download the file and copy to the DVD disk. I assume the file is still ufs.

Background- geom disk list shows the cdrom as cd0; /dev shows the file (?) cd0 and I created the directory /mnt/cdrom. The ls command confirms that the directory exists.

when I use the following command: root@machine:/ # mount -t ufs /dev/cd0 /mnt/cdrom
the command returns the following: mount: dev/cd0: Invalid argument

I have tried a few other options with no luck. Any advice would be appreciated
 
OP
OP
G

George Daxon

Member


Messages: 21

Thanks ASX. I tried the command as typed, but still getting /dev/cd0: invalid argument.

is it trying to say that /dev/cd0 is not valid?????

The file extension is .tgz. Do you think the disk was formatted in a different format system by my windows computer
 
OP
OP
G

George Daxon

Member


Messages: 21

Currently I am using 11.0 Release. Would it be easier to go to a 10 or a 9 series release that already has ntfs-
 
A

ASX

Guest


is it trying to say that /dev/cd0 is not valid?????
I'm not 100% sure but I think that error is printed on a range of cases: incorrect filesystem, read failure, wrong device name.

You can use the dmesg command, after inserting the disk in the drive, and check the last lines ... you should find some reference to the loaded DVD ... The file extension is irrelevant at this stage (mount).
 
OP
OP
G

George Daxon

Member


Messages: 21

The dmesg correctly identified the cd and I did not see an error message in the cd portion of the output. I did see an error message at the bottom "Unsupported partition map: *UDF Virtual Partition". I googled UDF and I understand that it is a specification called ISO/IEC 13346. I took a shot in the dark and inserted 13346 in the mount command and it did not work. Does this mean the Asus DVD/CD drive is not supported or that the UDF format is not supported?
 
A

ASX

Guest


It means that FreeBSD doesn't fully support the UDF = ISO 13346 format, it is a shame but that's the reality.
 
OP
OP
G

George Daxon

Member


Messages: 21

Understood....is that caused by the type of DVD disk I chose, the windows computer formatting the disk, or the Asus DVD drive?
 
A

ASX

Guest


No, it is a software choice: The ISO9660 format was made for CD optical media and has its own limits, in example maximum filesystem size is 4 GB. Upon introduction of DVDs, the ISO 9660 was extended to support larger size (4.7 GB and more), and other filesystem attributes, that was called UDF (universal disk format).

Now, it is possible tu burn a DVD using either ISO9660 or UDF, depending on the software you are using to burn the DVD and the related options. (I do not use Windows, so can't help here).

I would suggest to use a USB stick ... formatted as FAT32.
 
OP
OP
G

George Daxon

Member


Messages: 21

Just googled it, I need CD-r cd's and not the -rw CD. Is this correct?

What was confusing is I used the same type of DVD to load the system. I would have never guessed it
 
OP
OP
G

George Daxon

Member


Messages: 21

You are an awesome source of knowledge and I appreciate your help. I am kind of relieved that it was an unsupported format causing the problems. The alternative was to believe I could not learn a simple command (mount)....lol. I am going to try a USB sick formatted as FAT32.

I am going through the FreeBSD handbook and trying out the commands on this test system I'm using. I have been stuck on the mount command for days!!!!!! You can imagine my frustration level.

Thank You ASX! !!!!! !! ! !:)
 
OP
OP
G

George Daxon

Member


Messages: 21

Still cannot get the mount command to work. I formatted a usb as ext fat32 and tried the mount command. Did not work. I have searched the forums and this is what I found:

root@machine~# mount -v -t msdosfs /dev/da1 /mnt/USB. I also tried this with da1s1 and no luck. Any suggestions?
 
OP
OP
G

George Daxon

Member


Messages: 21

I think I am going to change to 10.3 release. I understand that earlier versions (earlier than 11) have better support for msdos based files and I don't have to install ntfs-3g.

I am not hell bent on using msdos, but currently everything I am willing to use on this test system is windows based. I have WD red hard drives (unformated) that I plan to use in my next build. The next system will use a FreeBSD based operating system. I don't want to use the new hard drives in this test system.
 
A

ASX

Guest


root@machine~# mount -v -t msdosfs /dev/da1 /mnt/USB.
/dev/da1 is the name for the raw device (whole stick, unpartitioned)
It may be possible you used the whole device, but usually is not the case:
most likely you will need to use something like /dev/da1p1 (GPT partition 1) or /dev/da1s1 (MBR partition 1).
use gpart show -p /dev/da1 to show the exact names, or verify with fstyp /dev/da1
 
A

ASX

Guest


the gpart command showed the following: da1 MBR (58G); da1s1 ntfs (58G)
That's not a fat32 filesystem, it should be labeled as msdos / fat / fat32 / vfat or something like that.
what return fstyp /dev/da1s1 ?
 
OP
OP
G

George Daxon

Member


Messages: 21

My apologies, the family redirected by attention. Funny how they can do that (wife does it with authority....lol).

However, I did take a day and go through some of the chapters in "Absolute BSD" and "Complete FreeBSD". I am starting to get the background knowledge needed to understand the system. I'm going to return to the forum once I get a few more chapters under my belt and I can be more coherent with problems. Thanks ASX, you were very patient with me.
 
OP
OP
G

George Daxon

Member


Messages: 21

Ok, I now have my FreeBSD system connected to the internet via an ethernet cable. I managed to assign a static IP address and I have successfully pinged the gateway.

How do I log into the system from my windows computer on the same LAN? The windows computer is using a wifi connection. Please note, I was not able to ping the windows computer from the FreeBSD computer.
 
Top