I can't detect my Wireless Card

ericjansen

New Member


Messages: 4

I installed FreeBSD 8.0 Release and upgraded into 8.1 Stable on my Toshiba L510 SYSTEM UNIT NOOS laptop (actually I don't know what is the serial/type number of this laptop). Previously, it was Windows vista installed and the ethernet and wireless cards were detected as Realteks'. Shortly, after FreeBSD installation, it's just ethernet card identified by the OS as "re0". I tried to check online regarding this type of ethernet card Realtek whether it works in two ways: LAN and wireless. Please observe from the followings. Afterward, what should I do to detect the wireless card whereabouts.

Code:
[root@eric ~]# dmesg
re0: <RealTek 8101E/8102E/8102EL/8103E PCIe 10/100baseTX> port 0x2000-0x20ff mem 0xd0410000-0xd0410fff,0xd0400000-0xd040ffff irq 16 at device 0.0 on pci2
re0: Using 1 MSI messages
re0: Chip rev. 0x24800000
re0: MAC rev. 0x00400000
miibus0: <MII bus> on re0
rlphy0: <RTL8201L 10/100 media interface> PHY 1 on miibus0
rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
re0: Ethernet address: 00:26:6c:69:e2:6c
re0: [FILTER]

Code:
[root@eric ~]# pciconf -lv
re0@pci0:2:0:0: class=0x020000 card=0xff1e1179 chip=0x813610ec rev=0x02 hdr=0x00
    vendor     = 'Realtek Semiconductor'
    device     = 'RTL8100E/RTL8101E/RTL8102E-GR (RTL8100-8101E-8102E-PCIEXPRESS)'
    class      = network
    subclass   = ethernet

Code:
[root@eric ~]# ifconfig -a
re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=389b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_UCAST,WOL_MCAST,WOL_MAGIC>
	ether 00:26:6c:69:e2:6c
	inet 192.168.1.77 netmask 0xffffff00 broadcast 192.168.1.255
	inet6 fe80::226:6cff:fe69:e26c%re0 prefixlen 64 scopeid 0x1 
	media: Ethernet autoselect (100baseTX <full-duplex>)
	status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
	options=3<RXCSUM,TXCSUM>
	inet 127.0.0.1 netmask 0xff000000 
	inet6 ::1 prefixlen 128 
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2

Code:
[root@eric ~]# cat /etc/rc.conf 
defaultrouter="192.168.1.1"
swapfile="/usr/swap0"
ifconfig_re0="inet 192.168.1.77  netmask 255.255.255.0"ipv6_enable="YES"
keymap="us.iso"
moused_enable="YES"
sshd_enable="YES"
dbus_enable="YES"
hald_enable="YES"
linux_enable="YES"
gnome_enable="YES"
fusefs_enable="YES"
ext2fs_enable="YES"
vboxnet_enable="YES"
inetd_enable="YES"

Code:
[root@eric ~]# cat /boot/loader.conf 
snd_hda_load="YES"
vboxdrv_load="YES"

Thank you in advance
 

sossego

Retired from the forums

Reaction score: 147
Messages: 1,557

Code:
apropos wireless && apropos realtek
Code:
dmesg|tee dmesg.txt && cat dmesg.txt| grep Realtek
Did you enable wireless with Fn+Fn-key-value? Not being an as but it may be necessary at times.

Also, have you tried using another BSD- such a jibbed or bsdanywhere- to see what it detects the cards as?
 

wblock@

Beastie Himself
Developer

Reaction score: 3,729
Messages: 13,851

ericjansen said:
Code:
[root@eric ~]# pciconf -lv
re0@pci0:2:0:0: class=0x020000 card=0xff1e1179 chip=0x813610ec rev=0x02 hdr=0x00
    vendor     = 'Realtek Semiconductor'
    device     = 'RTL8100E/RTL8101E/RTL8102E-GR (RTL8100-8101E-8102E-PCIEXPRESS)'
    class      = network
    subclass   = ethernet

You removed too much, that's the wired Ethernet. Try again:
# pciconf -lv | grep -B3 network

What this will probably show is the Realtek wireless for which there is no FreeBSD driver.

The two options are ndisgen(8) or replacing the Realtek card with something that is supported, like Atheros. Most people choose the first option.
 
OP
ericjansen

ericjansen

New Member


Messages: 4

Thank you for your efforts and helps. In the end, I searched in google the specification of the laptop (hints: Toshiba L510 intel dual core T4400 DDR3 1GB HDD 250GB realtek wireless). I found the manufacturer's type (Toshiba Satellite L510-B400) and it said "Realtek RTL8187B/L 802.11b/g wireless device". So I searched again in google and found the driver for thereof is urtw. Therefore, I loaded the driver in /boot/loader.conf:
Code:
if_urtw_load="YES"
and typed down in /etc/rc.conf:
Code:
wlans_urtw0="wlan0"
ifconfig_wlan0="DHCP"
And it works!

Thank you very much.
 
Top