Huawei E3372 LTE USB-stick

I have a Huawei E3372 LTE USB-stick, and am trying to find out its specification.

Unfortunately there are many different models, and I'm not sure which I have. Is there any way I can find which it is as well as the VID and PID.

I believe I need to use usb_modeswitch before I can use it with FreeBSD, but the specifics of how this should be done depends on which model it is AFAICT. At the moment when I plug it in I get a lot of cd0:umass errors because it has the wrong mode, presumably it is in storage mode.

Running lsusb shows
Bus /dev/usb Device /dev/ugen0.3:  ID 12d1:14fe Huawei .... (Mass Storage Mode)

Does ID show VID & PID?
Why not just trying to search the Internet for "12d1:14fe" (including the quotes)?
You will find many discussions about the modem and using usb_modeswitch for it.

Thanks, I never thought of doing a search like that. Interestingly the first it comes up with a Huawei E352s-5 so I guess the PID is not totally specific to the E3372 - the model I'm using, but I'll read on..
There is this guy with a post just like yours.

Stalled since May?

Yes that poor chap has been struggling to get the thing working for ages - he should probably take up gardening as a hobby :).

The problem is that the E3372 comes in two variants - HiLink/router-mode and Stick/modem-mode, but there is also storage mode which I need to change using usb_modeswitch. And there can be some jiggery pokery involved in switching between the two modes as you can see in this demo:

Apparently mine is a HiLink variety, but I'm still not sure which I need. I guess if I want to use a laptop as a WWAN-WLAN router that would be fine.

I'll just leave a couple of links here in case anyone needs them...
I think your wrong. Your modem is not in Hi-Link mode,
Just look at the ATI you posted in May

Manufacturer: huawei
Model: E3372

See the in your output
The page you referenced above says is Hi-Link.

Hi Link also does not allow AT command prompt, whereas you have an AT command prompt.

I think you need to follow these instructions to the tee. They are exactly what is needed.
I think your wrong. Your modem is not in Hi-Link mode,
Just look at the ATI you posted in May

I was told on a different forum that I have a Hi-Link modem

'Modems with serial numbers beginning with "G4P" are e3372h' Mine has G4PDW 158 17000240. Maybe it has been converted...
There is this guy with a post just like yours.

Stalled since May?
Actually May 2017!! ;) How time flies...

I've just rediscovered this dongle in my bag of tricks and thought I'd try using it again.

It worked when I tried it on OpenWrt the other day, without too much trouble, so I thought I repeat the exercise on FreeBSD, but can't get it to connect.

I'm trying to use RNDIS. if_urndis() is loaded. The device is recognised as a network card, ie no need for modesetting.

root@X1:/ # lsusb
Bus /dev/usb Device /dev/ugen0.4: ID 12d1:1506 Huawei Technologies Co., Ltd. Modem/Networkcard

root@X1:/boot/defaults # kldstat
Id Refs Address                Size Name
 1  110 0xffffffff80200000  1f3e2d0 kernel
 2    1 0xffffffff8213f000     bec8 autofs.ko
 3    1 0xffffffff82320000   1808b8 i915kms.ko
 4    1 0xffffffff824a1000    72bd8 drm.ko
 5    1 0xffffffff82514000     22b0 iic.ko
 6    2 0xffffffff82517000     30fc linuxkpi_gplv2.ko
 7    3 0xffffffff8251b000     62d8 dmabuf.ko
 8    1 0xffffffff82522000    11cd8 fusefs.ko
 9    1 0xffffffff82534000     3378 acpi_wmi.ko
10    1 0xffffffff82538000     3250 ichsmb.ko
11    1 0xffffffff8253c000     2180 smbus.ko
12    1 0xffffffff8253f000     4cfc geom_uzip.ko
13    1 0xffffffff82544000     3340 uhid.ko
14    1 0xffffffff82548000     4350 ums.ko
15    1 0xffffffff8254d000     3380 usbhid.ko
16    1 0xffffffff82551000     31f8 hidbus.ko
17    1 0xffffffff82555000     3480 umodem.ko
18    2 0xffffffff82559000     4d90 ucom.ko
19    1 0xffffffff8255e000     4640 if_cdce.ko
20    3 0xffffffff82563000     3178 uether.ko
21    1 0xffffffff82567000     4d00 ng_ubt.ko
22    6 0xffffffff8256c000     aac8 netgraph.ko
23    2 0xffffffff82577000     a238 ng_hci.ko
24    4 0xffffffff82582000     25a8 ng_bluetooth.ko
25    1 0xffffffff82585000     e250 ng_l2cap.ko
26    1 0xffffffff82594000    1bee8 ng_btsocket.ko
27    1 0xffffffff825b0000     39c0 ng_socket.ko
28    1 0xffffffff825b4000     6660 u3g.ko
29    1 0xffffffff825bb000    1ae78 ext2fs.ko
30    1 0xffffffff825d6000     8500 if_ure.ko
31    1 0xffffffff825df000     e538 snd_uaudio.ko
32    1 0xffffffff825ee000     3380 if_urndis.ko

DHCPREQUEST on ue1 to port 67
DHCPREQUEST on ue1 to port 67
DHCPDISCOVER on ue1 to port 67 interval 6
DHCPDISCOVER on ue1 to port 67 interval 10
DHCPDISCOVER on ue1 to port 67 interval 21
DHCPDISCOVER on ue1 to port 67 interval 19
DHCPDISCOVER on ue1 to port 67 interval 5
No DHCPOFFERS received.
Trying recorded lease
bound: immediate renewal.
DHCPREQUEST on ue1 to port 67

Not sure what else is required...

On OpenWrt I have a section in /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr ''
        option netmask ''

config interface 'lan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wwan'
        option proto 'ncm'
        option device '/dev//cdc-wdm0'
        option pdptype 'IP'
        option apn 'internet'

Looks like I need some place to specify pdptype and apn...