MATE hp-systray not showing and not functional in MATE

cabriofahrer

Active Member

Thanks: 8
Messages: 136

#1
I have the following Problem with MATE: The hp-systray (hplip) is not showing up in the Panel as it should, although it is in the MATE autostart programs. It does show up in KDE4 and in XFCE4, but not in MATE. The process "hp-systry -x" is listed when doing a ps -x and when killing it and reloading it by command line, then the blue icon does show, but it is useless, because when right-clicking on it, only a grey bar shows instead of the hplip-menu as it should. Any idea what is wrong with MATE here? I installed it from packages, maybe one of it is wrong and should be recompiled from ports?
 

fernandel

Aspiring Daemon

Thanks: 137
Messages: 638

#2
I think it is something python related. It sometimes shows on my panel in Openbox but next doesn't. On GNOME3 almost never.
And in the ~/.hplip/hp-upgrade.log is:
"warning: distro is not in AUTH_TYPES"
--------------
/usr/local/share/hplip/systray.py:

/usr/local/share/hplip/systray.py

HP Linux Imaging and Printing System (ver. 3.17.11)
System Tray Status Service ver. 2.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

/usr/local/lib/python2.7/site-packages/gtk-2.0/gtk/__init__.py:127: RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK
set_interactive(1)
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-ajtim'

HP Linux Imaging and Printing System (ver. 3.17.11)
HPLIP upgrade latest version ver. 1.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

sh: lsb_release: not found
cat: /etc/issue: No such file or directory
warning: distro is not found in AUTH_TYPES

For me works.


An
 
OP
OP
C

cabriofahrer

Active Member

Thanks: 8
Messages: 136

#3
I have no idea. In xfce it always works, in kde4 and fluxbox as well, I have even tried kde5 and it also works. I contacted the developer responsible for porting MATE a long time ago and he did not know, all he said it worked for him but that he was using FreeBSD-Stable, while I use RELEASE.
 
Top