hp Deskjet f4480 usb printer

Hello out there. I've been trying to connect my printer to hplip for the last month or so. I've read all the articles posted and still can't get my printer to hook up. When I run dmesg I get the following
gen5.2: <HP> at usbus5
ulpt0: <HP Deskjet F4400 series, class 0/0, rev 2.00/1.00, addr 2> on usbus5
ulpt0: using bi-directional mode
And when I run HP device manager I get this error message:
No device found
So from there I went to my command line and type in ls -l /dev/ugen5.2 and got this:
lrwxr-xr-x  1 root  wheel  9 Mar 16 07:42 /dev/ugen5.2 -> usb/5.2.0
Ok, so next I configure /etc/rc.conf and set up cupsd and devfs system ruleset system (all with the underscore and " "). To tell you the truth I'm out of answers right now so is there anybody who has figured it out? (Oh by the way I'm running FreeBSD 10.2 amd64).
Thank you.
There could be several things wrong.

1) USB printers can be connected to any available USB port on the computer. When FreeBSD detects a USB printer, two device entries are created: /dev/ulpt0 and /dev/unlpt0. Data sent to either device will be relayed to the printer. After each print job, ulpt0 resets the USB port. Resetting the port can cause problems with some printers, so the unlpt0 device is usually used instead. unlpt0 does not reset the USB port at all. Both unlpt0 and ulpt0 need to have the correct permissions as described in
FreeBSD cups

2) I don't currently use hplip/cups but the hplip configuration interface is not known for it's robustness. An alternative is to use the cups browser interface: http://localhost:631

3) Some typos in your /etc/rc.conf and/or /etc/devfs.rules. The forum allows newbies to post code using the code tags so others can review.
thanks for the info will delete hplip/cups
print/cups-filters is a dependency of print/hplip. I read recently that print/cups has also been consolidated, Thread 55472, and I do not know if that altered the setup tasks.

If you want to easily access the scanner part of your MultiFunctionPrinter you will need hplip - it provides a means to switch the usb port between printer and scanner. If you just want to print you have 4 options which I'll will list in order of decreasing complexity:

1) hplip/cups
2) cups
4) LPRng - rarely used these days
3) FreeBSDs' built in lpr print system.

You can use scanner with the last 3 options but I believe that you have to manually switch the usb port.

Edit: Grammer and added LPRng
I'm having the same problem, with the same series of HP printer (on FreeBSD 11.0). print/hplip has vulnerabilities, and I wanted to try lpr instead. When I did try to get around hplip's vulnerabilities and install anyway, my driver didn't show up, even though I checked it, and kept reinstalling it from scratch. Maybe I'll try that again when hplip's dependency vulnerabilities go away.

The scan function has worked only with hplip installed, but I just want to use the print function by itself at this point. Perhaps this suggests that it requires a .ppd file for print to work?

ulpt0: <HP Deskjet F4400 series, class 0/0, rev 2.00/1.00, addr 2> on usbus5
ulpt0: using bi-directional mode
ulpt0: output error
When I print, it stays in the queue, and lpq gives
Warning: no daemon present
Rank   Owner      Job  Files                                 Total Size
1st    root       11   links.txt                   1881 bytes
even after I keep starting lpd, and it was enabled in rc.conf. I've changed the usb cable, and I'm out of new cables to try. With one usb cable that warning went away, but perhaps it is fragile that I turned my printer over it, to look at it, but that shouldn't have kinked the cables.

There was an improvement earlier when I added back legacy support in src.conf, more hardware was recognized, and it was able to scan (with hplip and sane-backends). Could it be pf.conf (lo was skipped) or something else in src.conf? I've actually tried from a fully installed base system, and it didn't work then. Maybe I need the ppd driver to work with lpr? or is lpr just not compatible with HP printers?

What protocols does lpr use to communicate with the printer?

Jan  5 07:29:52 x newsyslog[720]: logfile first created
Jan  5 07:29:53 x lpd[890]: lpd startup: logging=0
Jan  5 18:06:33 x lpd[904]: lpd startup: logging=0
Jan  5 18:09:36 x lpd[888]: lpd startup: logging=0
Jan  5 18:14:52 x lpd[1725]: /dev/ulpt0   : No such file or directory
Jan  5 18:15:01 x lpd[1732]: lpd startup: logging=0
/dev/ulpt0 and /dev/unlpt0 show up in /dev/

I tried :lp=/dev/unlpt0\ too. chkprintcap gave no errors.

* update, going to compile device ulpt into kernel and remove lpt from it.
* No effect, perhaps it /dev/ulpt0 and /dev/unlpt0 permissions.