Solved HP 8460p RAID0 Matrix

I wan to do RAID0. First I enable RAID at the BIOS menu, and manual tell do it at
Intel Rapid Storage Technology at Windows.

Is exist any way to do RAID0 for FreeBSD on this HP?
"Intel Matrix" RAID, if that's what it is (the top Google hit for "HP 8460p RAID" is for that), can be used via graid(8). Historically, I believe the support for it has been better if the BIOS side of the RAID is disabled, and it is just managed as a standard soft RAID inside FreeBSD.

Usual warning: RAID0 is bad for reliability, it increases the chance of data loss, as a single drive failure will take out the entire RAID volume.
Use gstripe(8) or ZFS instead if at all possible. That one looks like one of the many variations of "PseudoRAID" that should be avoided because it uses a non-portable labeling method so you can't transfer the array to a new system unless the new system has the exact same RAID BIOS. The PseudoRAID also has no performance benefits over the other solutions.
I am not sure you can boot from gstripe Raid0 either. ZFS has root on raid so that might work.
I need to try it out myself as I would like to see if UFS/gstripe/RAID0 boots. I use industrial drives and I really think they are capable.
Obviously depends on usage. I would have all my working files on a fileserver and a core backup image of the box just in case.
Here is gmirror in action. I suspect gstripe would operate similarly.

Here is the root on ZFS page. I note it uses a mirror as well.
graid(8) is unusual in that it supports multiple manufacturer motherboard RAID metadata. In other words, you might be able to create that motherboard RAID on one system and use it with graid(8) on a different vendor's motherboard. I have not tested that.
You could install FreeBSD onto a USB drive and use your dual bays for the RAID0 for an easy experiment without the bootable array hassle.
I would think you would set st0 active --as it is the stripe volume-- if your trying to boot from it.

I will try this approach this weekend. it is too hot to be outside.
Do I see that right, That drives are different size? That sure would complicate things. Ideally you use identical drives all the way down to batches and firmware versions.
Ok I istall correctly (I wrote how leater) but BIOS sey "missing operating system" How to gpart set -a active on drive because /dev/stripe/st0 is operation no supported, /dev/ada0, /dev/ada1 is Invalid Argument...
I think you hit the wall. I was looking through the /boot folder and noticed a special file called gptzfsboot. I bet this is part of some special mechanism built to accommodate ZFS booting. No such file exists for gstripe.
Don't use gstripe(8) at all.

Go into the BIOS and create your striped array.

Boot into the FreeBSD installer, and install it on the array. If graid(8) is loaded, it will see the array as a device. Install to that. Don't use GPT, use old-style MBR slices and FreeBSD partitions.

If FreeBSD does not see the RAID device, escape into the loader prompt and load the graid(8) module before booting.
Looking at the Root on ZFS page I see that step 5 involves copying gptzfsboot to the disk.

I did get to learn diskinfo -t in this exercise. I was testing drives to use. My first choices were bad at 112 MegaBytes/sec. each. I don't have a lot of drive-pairs laying around. My Intel 520 drive gave me 330 Megabytes/sec.

I made an array with NAS4Free and was surprised GPartEdit Live was able to see it. Read Only. I could not make it active.
FreeBSD could see it but not mount it. It was using GPT as NAS4Free first formats the disk as Software Raid.

I will try motherboard raid0 now. QM77 chipset Dell
I'm reasonably sure that the wiki page is long out of date.

Just to be clear, I am not recommending RAID0 in any form. rf -rf seems faster and more predictable.
If you have not already done so, please read the handbook section about graid(8).

This is different to the page linked earlier, which was for gstripe(8).

And yeah, GPT is incompatible with many of the other geom(4) classes for entire-disk mode. It is a bug that gpart(8) silently lets you create a GPT scheme inside those classes (if it still does that, I've not tried it in a long time). They can be used with care inside individual GPT partitions, with the exception of graid(8), which must be an entire-disk setup for the BIOS to properly deal with it.

MBR or BSD partitioning is the safe option in general, unless you need something from GPT (such as EFI booting, or 2TB+ drives). BSD64 partitioning is another valid but uncommon option for 2TB+ drives. As far as the mentions of "dangerously dedicated" for BSD partitioning go, it's only dangerous if you let other operating systems (or any non-BSD tools, e.g. from bootable diags or the BIOS) meddle with the drives, it's not dangerous on a system which only ever runs BSD. Many people happily use BSD partitioning on dedicated BSD systems without any issues.

The 8.0 release notes were very badly worded when they suggested that "dangerously dedicated" would not work, and did not give a true impression of what does and does not work; in case you find any references to "not supported" in that context. It was just removed from the installer to reduce the chance of novices shooting themselves in the foot. The actual ability of the OS to safely use dedicated BSD label drives was unchanged.
Sorry for confusion I found, and enable BIOS menu respons for create RAID dervice, but is inpossible to create RAID to eSATA, I was buy second SSD and HDD pocket, but thanks for help! :)