How to use synaptics touchpad with FreeBSD

Rajesh

Member

Thanks: 3
Messages: 40

#1
Hi,

I am trying to use synaptics touchpad driver with FreeBSD. From wiki, I see we need to set hw.psm.synaptics_support to enable driver for synaptics touchpad. I tried setting this tunable, also loaded the necessary i2c driver. But I am not able to move the mouse pointer. Am i missing anything? I also tried setting moused_enable="YES" in /etc/rc.conf, but no luck. I suspect whether the psm driver itself is not loaded.

kldstat -v | grep psm :
436 acpi/psmcpnp
435 isa/psmcpnp
434 atkbdc/psm

Any clue?
 

ShelLuser

Son of Beastie

Thanks: 1,377
Messages: 2,938

#2
FreeBSD or Xorg? FreeBSD itself doesn't use a mouse you know ;)

Did you install x11/xorg? Because that port depends on x11-drivers/xf86-input-synaptics which should be enough to get this working.

(edit)

I'll look into that wiki because that seems like flawed info to me (at first impression). Normally you only need to install the port and then things should work.
 

scottro

Daemon

Thanks: 408
Messages: 1,208

#3
I've found that sometimes it works and sometimes it doesn't, from 10.x to 11.2. (The wiki instructions). Currently, working for me on a Lenovo Yoga2 and not working on a Thinkpad L420.
 
Top