How to resume after suspend? (Fujitsu A3511)

I got myself a laptop. I chose that one since the hardware appeared to be well supported. And indeed everything works with 13.1.

Except resume.

Suspend/resume works on all my machines. It works on the server (where I certainly can't use it), it works on the desktop (where I not really need it), but not on this one.
It does suspend after zzz (power led slowly flashing), but
  • the keyboard is not monitored, it does not react on keystrokes
  • the power button does a full power-on boot
  • lid-open does a full power-on boot
I try to do this in single-user. I tried to disable almost all peripherials in the bios, with no change.

Then I tried linux, booting from a live-stick. And there it works, the keyboard is monitored, and pressing any key gives a login screen immediately.

So it is not a hardware problem, and it should be possible to make it work. But it doesn't seem resume would even be tried. It apparently doesn't reach /etc/rc.resume.

debug.acpi.suspend_bounce=1 just runs through without error.
bug #260994 is probably not the issue, the behaviour is the same whether kmod are loaded or not, or X running or not.

I'm a bit out of ideas at the moment...
 
Try this. Just the instructions at the end of the thread.
This fixed it for me on 2 different machines.

 
OP
PMc

PMc

Thank You. Tried it, and sadly, this doesn't help here.

My problem is not about getting devices or applications or GUI back after resume, it is that apparently resume is not even tried.

But yesterday I booted a stick with OpenBSD 7.1, and there it works. I didn't get the devices back, but I got the previously running OS with the console prompt (that would then report I/O error on file access).
 
Top