How to prevent scroll when clicking left and right (in firefox)?

JonaEngel

New Member


Messages: 5

On a thinkpad t470p running x11/xorg 7.7_3 under FreeBSD 12.2-RELEASE-p1. When I use the trackpoint and corresponding mouse buttons as well as touchpad, in e.g. www/firefox, clicks on the left button scroll up and clicks right scroll down.
In some applications, such my terminal or graphics/xpdf the mouse clicks do not scroll (which I like).
I am running no specific xorg configuration file, but let xorg figure things out it self. Which works great for everything I need except this internal mouse (track point and trackpad).
Using an external mouse, clicks do not scroll. I have x11-drivers/xf86-input-synaptics 1.9.1_7 installed.

How can I disable this scrolling?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,164
Messages: 35,668

When I use the trackpoint and corresponding mouse buttons as well as touchpad, in e.g. www/firefox, clicks on the left button scroll up and clicks right scroll down.
This sounds like caret browsing is turned on, try hitting F7.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,164
Messages: 35,668

Another thing, this may be happening:
Code:
Some laptops, most notably the Lenovo T440, T540	and x240 series,  pro-
       vide  a	pointing stick without physical	buttons. On those laptops, the
       top of the touchpad acts	as software-emulated button  area.  This  area
       can  be	enabled	 with  Option "HasSecondarySoftButtons"	and configured
       with Option "SecondarySoftButtonAreas".	On some	platforms, this	option
       will  be	 set automatically if the kernel detects a matching device. On
       Linux, the device must have the INPUT_PROP_TOPBUTTONPAD property	set.

Check the synaptics(4) man page, there's an extraordinary amount of options you can set and/or change.
 
OP
J

JonaEngel

New Member


Messages: 5

Unfortunatly caret brwosing was not it.
I am not sure if it is a `synaptics` thing. The device has hardware buttons.
I tried a bit, not success so far.
 

jans

New Member

Reaction score: 1
Messages: 8

I have a similar problem after upgrading to 12.2 on my Thinkpad X250. Clicking the left button scrolls up instead of triggering a click event. The right button however, works as expected. On 12.1 I had no problems.

My Xorg.0.log: https://termbin.com/k39i

Any idea what might cause this behavior?
 

jans

New Member

Reaction score: 1
Messages: 8

Thanks!
xmodmap -e "pointer = 1 2 3 0 5 6 7"
resolves my problem to a certain degree (that is, scrolling up and down with two fingers does not work anymore, but the left click works as expected).
 

Snurg

Daemon

Reaction score: 426
Messages: 1,054

Best option would be to get rid of libinput, and re-enable evdev, of course.
But, the Wayland faction made a lot of effort to make this as difficult as possible.
 
Top