Xfce How to disable bsdisks automounter?

bsduck

Active Member

Reaction score: 161
Messages: 212

Hello,

Xfce in FreeBSD has been recently including by default a new automounting system, using sysutils/bsdisks.

I experimented a bit with various external drives, and found it totally unreliable as of now.

With the disk formatted
... as UFS, it shows two entries in Thunar (one for /dev/da0 and one for /dev/da0p1) for a single partition disk.
... as ext2, it cannot mount it.
... as exFAT, I end up with gvfs-udisks2-volume-monitor hanging at high CPU usage, when unmounting the disk from Thunar.
... as FAT32, it fails to mount it and crashes, if the disk has UTF-8 filenames (for which there is the -L xx_XX.UTF-8 option when using mount_msdosfs).

I don't understand how such a buggy piece of software can be installed and enabled by default. I have nothing against automounting, but no automounting is for sure better than a mechanism that fails most of the time, being more of an annoyance than something useful.

How can I disable this? I cannot remove bsdisks without breaking dependencies.
 

Jaekelsson

New Member

Reaction score: 5
Messages: 14

I had this problem with XFCE.

I had to disable bsdisks :
The only solution i found is to rename or delete the file :
/usr/local/share/dbus-1/system-services/org.freedesktop.UDisks2.service
bsdisks won't start again.

I'm searching for a better solution.
 
Top