How to declare keyboard under Gnome3

philo_neo

Active Member

Reaction score: 1
Messages: 244

Hi,
I have installed FreeBSD 11 with Gnome3, iI can't declare keyboard "fr", iI tried many scripts at xorg.conf file but the keyboard is still "qwerty", also the rc.conf file iI have declare "fr", so when my system start the VT terminal are "azerty" but when iI start the gnome3 iI lose the config "fr", my question is how to declare keyboard "fr"?

Best regards,
Philippe
 

Juanitou

Well-Known Member

Reaction score: 124
Messages: 453

Hi Philippe, I’ve never used Gnome, but this section in xorg.conf has worked for me with Mate, Openbox and Lumina:
Code:
Section "InputClass"
   Identifier "system-keyboard"
   MatchIsKeyboard "on"
   Option "XkbLayout" "fr"
   Option "XkbVariant" "latin9"
EndSection
 
OP
OP
philo_neo

philo_neo

Active Member

Reaction score: 1
Messages: 244

Hi Philippe, I’ve never used Gnome, but this section in xorg.conf has worked for me with Mate, Openbox and Lumina:
Code:
Section "InputClass"
   Identifier "system-keyboard"
   MatchIsKeyboard "on"
   Option "XkbLayout" "fr"
   Option "XkbVariant" "latin9"
EndSection
Hi,
I try your section into xorg.conf, but now I think about mistake into xorg.conf because is blank just adding your section, when I do the command xorg -reconfigure I have errors if you are interesting about last one, I can paste it!
I have read many links, so my question is how to fill the xorg.conf?

Regards
Philippe
 

Juanitou

Well-Known Member

Reaction score: 124
Messages: 453

As far as I know, you don’t need to use xorg -reconfigure. Just put the snippet provided above in /etc/X11/xorg.conf and Xorg should automatically configure the rest when starting up.
 
OP
OP
philo_neo

philo_neo

Active Member

Reaction score: 1
Messages: 244

Hi,

I found the line command is :
setxkbmap fr

Regards,
Philippe
 

Juanitou

Well-Known Member

Reaction score: 124
Messages: 453

Yes, there are different ways to do it. You can also replace the above mentioned lines in xorg.conf by the following line in ~/.xinitrc (provided you start the Xorg server with startx(1):
Code:
setxbmap -model pc105 -layout fr -variant latin9 &
 

tetragir

Member

Reaction score: 16
Messages: 82

Hi,

Just to be sure, did you tried to set the layout from Gnome's own Settings panel?
It's in Settings > Region & Language > Input Sources. You have to add the France layout and delete everything else (if you don't need it fo course).
 

User7

Active Member

Reaction score: 7
Messages: 123

% setxkbmap fr Will be NOT working after reboot :)


Try: bsdconfig syscons_keymap

and add this section to /etc/X11/xorg.conf and reboot machine.

Code:
Section "ServerFlags"
  Option "DontZap"  "off"
  Option "AllowEmptyInput" "off"
  Option "AutoAddDevices"  "off"
EndSection
 
OP
OP
philo_neo

philo_neo

Active Member

Reaction score: 1
Messages: 244

Yes, there are different ways to do it. You can also replace the above mentioned lines in xorg.conf by the following line in ~/.xinitrc (provided you start the Xorg server with startx(1):
Code:
setxbmap -model pc105 -layout fr -variant latin9 &
Hi,
I didn't do a startx !
I have wrote into ~/.xinitrc the command exec /usr/local/bin/gnome-session. I tried to add the command setxbkmap but it is wrong!
Which files are use by Gnome?

Regards
Philippe
 
Top