How to create dial-up on mpd5

andrian

Active Member

Reaction score: 6
Messages: 147

Hi friends. Please help me. I need create dial-up on FreeBSD Release-9.3x64 use net/mpd5 port.
I have a problems in dial moment. Log /var/log/mpd.log wrote:
Code:
May 25 15:58:35 lvho01srfs03 mpd: [] WEB: link L1
May 25 15:58:35 lvho01srfs03 mpd: [L1] WEB: open
May 25 15:58:35 lvho01srfs03 mpd: [L1] Link: OPEN event
May 25 15:58:35 lvho01srfs03 mpd: [L1] LCP: Open event
May 25 15:58:35 lvho01srfs03 mpd: [L1] LCP: state change Initial --> Starting
May 25 15:58:35 lvho01srfs03 mpd: [L1] LCP: LayerStart
May 25 15:58:38 lvho01srfs03 mpd: [L1] CHAT: Detected Hayes compatible modem.
May 25 15:58:38 lvho01srfs03 mpd: [L1] CHAT: Dialing server at 777...
May 25 15:59:23 lvho01srfs03 mpd: [L1] CHAT: No response from the modem after dialing.
May 25 15:59:23 lvho01srfs03 mpd: [L1] [COLOR=#ff4d4d]MODEM: chat script failed[/COLOR]
May 25 15:59:23 lvho01srfs03 mpd: [L1] Link: DOWN event
May 25 15:59:23 lvho01srfs03 mpd: [L1] LCP: Down event
May 25 15:59:23 lvho01srfs03 mpd: [L1] Link: reconnection attempt 1 in 2 seconds
May 25 15:59:25 lvho01srfs03 mpd: [L1] Link: reconnection attempt 1
May 25 15:59:29 lvho01srfs03 mpd: [L1] CHAT: Detected Hayes compatible modem.
May 25 15:59:29 lvho01srfs03 mpd: [L1] CHAT: Dialing server at 777...
May 25 15:59:51 lvho01srfs03 mpd: [] WEB: link L1
May 25 15:59:51 lvho01srfs03 mpd: [L1] WEB: close
May 25 15:59:51 lvho01srfs03 mpd: [L1] Link: CLOSE event
May 25 15:59:51 lvho01srfs03 mpd: [L1] LCP: Close event
May 25 15:59:51 lvho01srfs03 mpd: [L1] LCP: state change Starting --> Initial
May 25 15:59:51 lvho01srfs03 mpd: [L1] LCP: LayerFinish
May 25 15:59:51 lvho01srfs03 mpd: [L1] Link: DOWN event
May 25 15:59:51 lvho01srfs03 mpd: [L1] LCP: Down event
but not dial.
Phone number "777" is my internal number connect to phone from mini ATC. Server has phone number is "773" connect to mini ATC over dial modem.
When call on number "777" from command line by using #cu -l /dev/cuau0 -s 9600
Code:
#Connect
#at ok
#atdt777
....
all good.
Please help, which $InitString for dial-up call in /usr/local/etc/mpd5/mpd.conf.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,358
Messages: 33,929

What exactly happens when the server picks up the call?
 
OP
andrian

andrian

Active Member

Reaction score: 6
Messages: 147

Ok. This wrote tail -f /var/log/mpd.log
Code:
May 27 15:13:47 lvho01srfs03 mpd: process 39875 terminated
May 27 15:13:47 lvho01srfs03 mpd: Multi-link PPP daemon for FreeBSD
May 27 15:13:47 lvho01srfs03 mpd:
May 27 15:13:47 lvho01srfs03 mpd: process 39968 started, version 5.8 (root@lvho01srfs03 15:21 29-Apr-2016)
May 27 15:13:47 lvho01srfs03 mpd: CONSOLE: listening on 127.0.0.1 5005
May 27 15:13:47 lvho01srfs03 mpd: web: listening on 0.0.0.0 5006
May 27 15:13:47 lvho01srfs03 mpd: [B1] Bundle: Interface ng0 created
May 27 15:14:00 lvho01srfs03 mpd: [] WEB: link L1
May 27 15:14:00 lvho01srfs03 mpd: [L1] WEB: open
May 27 15:14:00 lvho01srfs03 mpd: [L1] Link: OPEN event
May 27 15:14:00 lvho01srfs03 mpd: [L1] LCP: Open event
May 27 15:14:00 lvho01srfs03 mpd: [L1] LCP: state change Initial --> Starting
May 27 15:14:00 lvho01srfs03 mpd: [L1] LCP: LayerStart
May 27 15:14:03 lvho01srfs03 mpd: [L1] CHAT: Detected Hayes compatible modem.
May 27 15:14:03 lvho01srfs03 mpd: [L1] CHAT: Dialing server at 777...
May 27 15:14:48 lvho01srfs03 mpd: [L1] CHAT: No response from the modem after dialing.
May 27 15:14:48 lvho01srfs03 mpd: [L1] MODEM: chat script failed
May 27 15:14:48 lvho01srfs03 mpd: [L1] Link: DOWN event
May 27 15:14:48 lvho01srfs03 mpd: [L1] LCP: Down event
May 27 15:14:48 lvho01srfs03 mpd: [L1] Link: reconnection attempt 1 in 1 seconds
May 27 15:14:49 lvho01srfs03 mpd: [L1] Link: reconnection attempt 1
May 27 15:14:55 lvho01srfs03 mpd: [L1] CHAT: Detected Hayes compatible modem.
May 27 15:14:55 lvho01srfs03 mpd: [L1] CHAT: Dialing server at 777...
 
OP
andrian

andrian

Active Member

Reaction score: 6
Messages: 147

this my section for dialup in mpd.conf
Code:
dial_nbu:
# Create static modem link named L1
  create link static L1 modem
# Configure modem
  set modem device /dev/cuau0
  set modem speed 9600
  set modem var $DialPrefix "ATDT"
  set modem var $Telephone "777"
  set modem script DialPeer
  set link no pap chap eap
  set link accept pap
  set modem idle-script Ringback
# We expect to be authenticated by peer using any protocol.
#  set link disable chap pap
#  set link accept chap pap
# Configure the account name. Password will be taken from mpd.secret.
  set auth authname Login
# To make Ringback work we should specify how to handle "incoming"
# calls originated by it.
  set link action bundle B1
  set link max-redial 0
#  set link enable incoming

# Create static bundle named B1
  create bundle static B1
# Enumerate links participating in DoD
  set bundle links L1
# Configure the interface: dial on demand, default route, idle timeout.
  set iface addrs 0.0.0.0 1.1.1.1
#  set iface route default
#  set iface enable on-demand
#  set iface idle 900

# "Open" interface (but don't actually dial until there's demand)
#  open
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 9,358
Messages: 33,929

I'm sure the dialup is fine, I'm wondering what you are dialing into. If there's no proper reception the client isn't going to do much.
 
OP
andrian

andrian

Active Member

Reaction score: 6
Messages: 147

Yes, dialup is fine and "reconnection attempt" too, but not call on the phone (not ring sound). Why, when I use
Code:
#cu -l /dev/cuau0 -s 9600
Connect
at ok
atdt777
....
ring sound on the phone present, but from mpd5 not ring?
 
Top