Solved How to automount VBox shared folder?

badbrain

Active Member

Reaction score: 18
Messages: 121

I'm back. I no longer work for my previous team. That's means I no longer a seeder (for our commercial Linux distro, it's abandoned) and no longer a troller (that's people accused me, I've never intended to troll anyone). I'm have my desktop PC back with new hardware and this time I want to try FreeBSD seriously. As expected, it doesn't detect my USB dongle. So I stayed with Windows 7 as the host (I'm writing on Windows 7 because I give the VM all of the physical cores of the CPU and the maximum ram allowed by VBox so I can't run anything other than the VM the same time). The problem is VBox shared folder doesn't mount automatically like it does on OpenIndiana.

I installed FreeBSD 11.3 normally with guided Root On ZFS and install bash nano sudo xorg mate virtualbox-ose-additions virtualbox-ose-kmod slim slim-themes and set them up as usual. I changed bash to be my default shell (root's shell still tcsh), export EDITOR=nano and set visudo to allow anyone on group wheel to execute without password (including my user account). Added exec mate-session to .xinitrc.

Added /boot/loader.conf: vboxvfs_load="YES"

Added /etc/rc.conf:

dbus_enable="YES"
hald_enable="YES"
vboxguest_enable="YES"
vboxservice_enable="YES"
slim_enable="YES"

Then I reboot. I could see vbox addition started correctly on dmesg and I could change Mate Display to Full Screen resolution. That's mean vbox addition worked. Then I checked /mnt like on OpenIndiana to see if the shared folder mounted, it's not. I tried to mount_vboxsf manually with the share's name to be Share /sf_ that I taken from my MX Linux VM but it said "Share /sf_" not found. I don't know why.

Now I disabled Automount from the VM's setting and will report if I could mount it manually via Caja.
 
OP
OP
B

badbrain

Active Member

Reaction score: 18
Messages: 121

Not work either. I tried to add my user account to group vboxsf as I remembered on OpenIndiana it will mount the share automatically but requires I'm member of group vboxsf to have access to the share. FreeBSD said group vboxsf not existed.
 
OP
OP
B

badbrain

Active Member

Reaction score: 18
Messages: 121

I surprised no one reply. Perhaps people just install it on bare hardware.
 
OP
OP
B

badbrain

Active Member

Reaction score: 18
Messages: 121

Perhaps they feel that you didn't do enough (re)searching of the subject on your own?


Remember: to be able to ask smart questions, you must have done your homework on the subject first!
/usr/local/share/hal/fdi/policy/10osvendor/90-vboxguest.fdi no such file or directory :oops:
I ended up paste the file content from the handbook myself and could mount the share. Just it can't be mounted automatically like on OpenIndiana without adding it to fstab. My problem is I didn't notice the share's name on VBox setting so I use the name of the share of the other VMs :rolleyes:
 

LakeCowabunga

New Member

Reaction score: 1
Messages: 7

Expecting a reply in 133 minutes is a bit much. However, I too haven't gotten the share to auto-mount. (Which I don't mind.)
 
Top