How to add a scroll bar to a XTerm using FVWM Window Manager ?

R6exe

Member

Reaction score: 2
Messages: 32

Hello everyone.

I'm having some trouble trying to add a scroll bar into a Xterm terminal. I tried to find on the internet some way to get it work but I can't because I can't find the right config file, most of the tutorials that I saw were just for Arch Linux and as I can see Xorg is a little bit different in an Arch Linux environment than FreeBSD, and as I'm a newbie in Xorg I would like to ask to the community to help me.

As I understand, at least in FreeBSD the FVWM config file is in /usr/local/share/fvwm/default-config/config, but I think that is not the file that I need to make changes. Most tutorials used the file ~/.Xresources to add the scroll bar, I checked in my home directory for .Xresources, but I don't have it, and the xrdb command that I try to use to create it gives me this error: xrdb: can't display ''.

I searched a lot but in the end I couldn't make it.

I appreciate every answer even if this doesn't solution my problem.

At least I found one way to open the scroll bar but it's a little weird, and it's by using the command xterm with the parameter -sb.

Thank you very much for your help, cheers.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,691
Messages: 39,290

Most tutorials used the file ~/.Xresources to add the scroll bar, I checked in my home directory for .Xresources, but I don't have it,
You need to create this file.
 

Zirias

Son of Beastie

Reaction score: 1,698
Messages: 2,869

Furthermore, this has nothing to do with FVWM. X resources are a traditional way to configure X applications, xterm supports a lot of resource settings, you will find them in the man-page: xterm(1).
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,691
Messages: 39,290

Create a ~/.Xresources with your settings. Load it with xrdb ~/.Xresources and open a new xterm to see your settings (if they're correct).

Add this to your ~/.xinitrc (somewhere at the top):
Code:
[ -f "${HOME}/.Xresources" ] && xrdb "${HOME}/.Xresources"
That will make sure it's loaded when you login (or run startx).
 
Top