How do you start the new kde5?

cabriofahrer

Active Member

Reaction score: 14
Messages: 238

I have just installed the new kde5 with pkg install kde5, but how do I start it? Before with kde4 I could do a service kdm4 onestart, but that does not work anymore, even if I leave out the "4" or type a "5" instead. What's happening here? Does kdm not exist anymore or does it have to be installed separately?
 
OP
C

cabriofahrer

Active Member

Reaction score: 14
Messages: 238

Thank you very much! Meanwhile I found this out, too and installed it. But it looks like I am not very delighted with kde5 at all. I think I am gonna dump this again...
 

knightjp

Active Member

Reaction score: 34
Messages: 175

Since it has taken so long for Plasma to come to FreeBSD, I am assuming that the current port is not Plasma 5.13. Am I correct?
 

zeissoctopus

Active Member

Reaction score: 40
Messages: 167

You many start plasma desktop by startx with .xinitrc which ends with the following command startkde
 

tcb

New Member


Messages: 2

Since it has taken so long for Plasma to come to FreeBSD, I am assuming that the current port is not Plasma 5.13. Am I correct?
Plasma 5.13 requires an update to the libinput ports. That's why it hasn't yet been updated in the ports tree.

If you want to try it, it is in the development repo.
 

Yampress

Active Member

Reaction score: 23
Messages: 136

You should install sddm
and add into /etc/rc.conf
Code:
sddm_enable="YES"
and reboot


or
install sddm and run
Code:
service  sddm onestart
 

Alexander88207

Well-Known Member

Reaction score: 237
Messages: 432

sddm="yes" gives me login and the an X with nothing

On the login screen is "Plasma (Wayland)" selected?

This is now default for some reason, and it dont work for me.

but i don't care about it because wayland is not interesting for me at the moment.
 

rvgeerligs

New Member


Messages: 7

On the login screen is "Plasma (Wayland)" selected?

This is now default for some reason, and it dont work for me.

but i don't care about it because wayland is not interesting for me at the moment.
Hi, thx. But as I select Plasma instead of wayland. Everything gets too small for me to click anywhere. But it is a step forward.
 

Mjölnir

Daemon

Reaction score: 1,463
Messages: 2,114

Hi, thx. But as I select Plasma instead of wayland. Everything gets too small for me to click anywhere. But it is a step forward.
The selection menu was too small for me to see. I have 4K monitor and I cannot seem to make this workable.
1st try if setting
Code:
[X11]
# This is only needed if your monitor supports DPMS; some laptop internal monitors do not
ServerArguments=dpms -nolisten tcp
# For modern high resolution displays
EnableHiDPI=true
in sddm.conf(5) helps. edit /usr/local/etc/sddm.conf. Of course, you have to service sddm restart
2. If that does not solve your issue, you can tell the video driver to use the correct resolution of your monitor:
edit /usr/local/etc/X11/xorg.conf.d/monitors.conf
Code:
# The Xserver(8) recognizes the dimensions of the monitor correctly, but
# later the video driver (e.g.intel(5))  sets them to much larger values.
# I guess this is considered a feature, intended to shrink the output on very
# small screens like subnotebooks/tablets/phones.
# Pro:
# + for the GUI it appears like a larger monitor, and more items can be
# placed on the sceen -- this improves the usability of these devices.
# + for developers it's much simpler to agree on a standard resolution
# (nowadays 96 DPI), and write their programs just for that.
# Then the requirements of different use-cases are done by scaling.
# Contra:
# - the server lies (intentionally) about the DPI, thus all the fonts are
# shrinked and often difficult to read, esp. when browsing the internet.
#
# While this may make sense on a smartphone/tablet, I want "the truth"
# on my 14" laptop.
# In a multi-monitor setup, the key is to link the monitor to the card in the
# device section of the graphics card: e.g. in
# /usr/local/etc/X11/xorg.conf.d/video.conf
# Section "Device"
#     Identifier  "<Intel HD Graphics 5500>"
#     Driver "intel"
#     Option "Monitor-LVDS1" "<Notebook internal LCD>" or
#     Option "Monitor-eDP1" "<Notebook internal TFT>"
#     Option "Monitor-DP2" "<external monitor (needs setup)>"
# EndSection
# You can also use "<default monitor>", which is default.
# NOTE: beware, naturally in a docking station the numbering changes:
# Option "Monitor-DP2-3" "<external LCD [VGA,docked]>"
#
Section "Monitor"
    Identifier          "<default monitor>"
    # these two should be enabled if DisplaySize is set below
    # You can grep(1) these values from /var/log/Xorg.0.log
    VendorName "CMN"
    ModelName "1482"
    Option "primary" "yes"
    # You can grep(1) these values from /var/log/Xorg.0.log
    # Although the Xserver(8) detects it, we have to tell intel(5) explicitely
    # to use this and not setting the wrong DPI.
    DisplaySize 309 174
EndSection
and restart sddm.
 
Top