Solved How do I get sound working on KDE5/FreeBSD 11.2?

ekingston

Active Member

Reaction score: 58
Messages: 225

Looking at the handbook, I should have sound working:

Code:
cat /dev/sndstat
Installed devices:
pcm0: <Realtek ALC295 (Analog)> (play/rec) default
pcm1: <Realtek ALC295 (Right Analog)> (play/rec)
pcm2: <Intel Kabylake (HDMI/DP 8ch)> (play)
No devices installed from userspace.
If I understood it right, it hsould be coming through PCM0 by default. So, it should be coming out the laptop speakers, I would think.

To check, I plugged in a set of headphones into the headphone jack and also connected the HDMI port to an HDMI monitor. No sound out of any of them.

So, how do I actually get it to play sound?

On the up side, the new intel drivers for X11 are playing videos from web sites really well.

Edit: Current solution is to use Gnome3 and remove KDE from my system.
 
Last edited:
OP
OP
E

ekingston

Active Member

Reaction score: 58
Messages: 225

Have you looked the volume on mixer(8)? Also, what is set as default on KDE sound settings?
I should have included mixer in the original post, thanks.
Code:
mixer
Mixer vol      is currently set to 100:100
Mixer pcm      is currently set to 100:100
Mixer speaker  is currently set to 100:100
Mixer rec      is currently set to  37:37
Mixer ogain    is currently set to 100:100
Mixer monitor  is currently set to  67:67
Recording source: monitor
KDE sound setting (Phonon Audio and Video doesn't have any devices listed. The Backend tab is similarly blank. I missing a group entry?
KDE5_Sound_Settings.png
 
OP
OP
E

ekingston

Active Member

Reaction score: 58
Messages: 225

Any ideas why the audio devices aren't showing up in the KDE settings page?
 
OP
OP
E

ekingston

Active Member

Reaction score: 58
Messages: 225

The Handbook sound chapter suggested an example test:
% [B]cat [I]filename[/I] > /dev/dsp[/B]

This produces appropriate noise. But I still don't see any chocies for seleting a device in the KDE settings.

Any ideas? Hints? Pointers? Config files I might not have modified?

[EDIT:] Sound plays fine through Firefox (package) but is silent in Konqueror. Tested through youtube (I double checked the video widget to be sure it wasn't muted).
 

abishai

Aspiring Daemon

Reaction score: 165
Messages: 720

hald is optional and used only in device mounting.
ekingston You can search the forum to find why devices are missing.
 

romanaOne

Member

Reaction score: 10
Messages: 79

I have nothing in my KDE5 System Phonon Audio and Video panel but sound works. What media players do you want to use?

I use VLC to play individual video/audio files and Clementine for the iTunes -like jukebox use..

What the hell is Phonon anyway? I think I heard the word sleeping though solid state years ago...zzzzz....lattice vibrations......
 
OP
OP
E

ekingston

Active Member

Reaction score: 58
Messages: 225

Have you started hald?
Yes. That resolved some other problems but still no audio in KDE5.

hald is optional and used only in device mounting.
ekingston You can search the forum to find why devices are missing.
I searched the forums and didn't find much of use. There was one thread with some vague hints that didn't do anything.

I solved my problem by dumping KDE and installing gnome instead. The UI is much uglier but the default music player works, the default video player works, and I get sound out of Youtube in the default browser. So, it wins.
 
OP
OP
E

ekingston

Active Member

Reaction score: 58
Messages: 225

I have nothing in my KDE5 System Phonon Audio and Video panel but sound works. What media players do you want to use?

I use VLC to play individual video/audio files and Clementine for the iTunes -like jukebox use..

What the hell is Phonon anyway? I think I heard the word sleeping though solid state years ago...zzzzz....lattice vibrations......
I don't know where they got the name "Phonon" from. But if the default applications aren't going to do what they are supposed to do (and I have actually set-up the OS layer correctly) then there is little point in keeping KDE on my system.

Why would the default GUI for the audio mixer not control the audio devices on the system? If it isn't compatible, why include it in the defaults. Given that I can control the audio devices manually with the FreeBSD mixer command.

Audio in FreeBSD was confirmed to work following the test from the handbook (including playing an MP3 file).
 

romanaOne

Member

Reaction score: 10
Messages: 79

Actually, I haven't installed any phonon-anything. I think I had a problem getting the a phonon-something port to compile...This was a while ago...I think it was complaining about a path that had an unset %%WEIRD_QT_ENVIRONMENT_VARIABLE%%

I neved used any of the KDE media players and AFAIK, they have always been terrible. I was surprised to find kmix working, so I'm still using KDE5.

I do have a bunch of gstreamer-{good,bad,ugly,spaghetti,western,etc} installed from when I was trying to get Apple Lossless to play.

Here are the options I picked configurating VLC:
Code:
Options        :
        A52            : on
        AALIB          : off
        ASS            : off
        AVAHI          : on
        CACA           : off
        DBUS           : on
        DCA            : on
        DOCS           : off
        DVDNAV         : on
        DVDREAD        : on
        FAAD           : on
        FLAC           : on
        FLUID          : off
        FREERDP        : off
        FRIBIDI        : off
        GME            : off
        GNOMEVFS2      : off
        GNUTLS         : on
        GOOM           : off
        HTTPD          : on
        JACK           : off
        KATE           : off
        LIBBLURAY      : off
        LIBRSVG2       : off
        LIBSSH2        : off
        LIRC           : off
        LIVEMEDIA      : on
        LUA            : on
        MAD            : on
        MATROSKA       : on
        MODPLUG        : off
        MPEG2          : on
        MTP            : off
        MUSEPACK       : off
        NCURSES        : off
        NLS            : on
        NOTIFY         : off
        OGG            : on
        OPTIMIZED_CFLAGS: on
        OPUS           : on
        PNG            : on
        PULSEAUDIO     : off
        QT4            : off
        QT5            : on
        REALRTSP       : off
        RUNROOT        : off
        SAMPLERATE     : on
        SCHROEDINGER   : on
        SDL            : off
        SHOUTCAST      : off
        SIDPLAY        : on
        SKINS          : on
        SMB            : off
        SNDIO          : off
        SPEEX          : on
        STREAM         : on
        TAGLIB         : on
        THEORA         : on
        TWOLAME        : on
        UPNP           : on
        V4L            : on
        VAAPI          : on
        VCD            : on
        VDPAU          : on
        VORBIS         : on
        X11            : on
        X264           : on
        X265           : on
        ZVBI           : off
 

b6s6d6

Member

Reaction score: 15
Messages: 36

To have a proper backend you only need one simple command:
sudo pkg install phonon-gstreamer-qt5
It would be better if it was pulled by the 'kde5' meta package...
 

zeissoctopus

Active Member

Reaction score: 40
Messages: 167

I use Plasma Desktop with PulseAudio and Postgresql 9.6 in my aged Acer Laptop. I compile them by ports-mgmt/poudriere
It produces a stable Plasma Desktop with sound to me. I use FreeBSD 11.2-Release

/usr/local/etc/poudriere.d/myJail-make.conf
Code:
DEFAULT_VERSIONS+=ssl=openssl pgsql=9.6 php=7.0 python=3.6
audio_kwave_SET=PULSEAUDIO
audio_kwave_UNSET=ALSA
audio_pulseaudio_SET=ALSA AVAHI BASH JACK GCONF SIMD SIMPLE SOXR SPEEX
audio_pulseaudio_UNSET=GDBM TDB ZSH
databases_akonadi_SET=PGSQL
databases_akonadi_UNSET=MYSQL SQLITE
multimedia_phonon_SET=PULSEAUDIO
multimedia_phonon-gstreamer_SET=GST_PLUGINS
multimedia_qt5-multimedia_SET=GSTREAMER PULSEAUDIO
multimedia_qt5-multimedia_UNSET=ALSA OPENAL
x11_plasma5-plasma-desktop_SET=PULSEAUDIO SCIM SYNAPTICS
/usr/local/etc/Poudriere-build-lists
Code:
audio/juk
audio/kwave
audio/plasma5-plasma-pa
databases/postgresql96-server
databases/py-psycopg2
devel/xdg-user-dirs
devel/xdg-utils
multimedia/phonon@qt5
multimedia/phonon-gstreamer@qt5
ports-mgmt/pkg
x11/kde5
x11/xorg
ports-mgmt/poudriere gets the job done with command
poudriere bulk -f /usr/local/etc/Poudriere-build-lists -j myJail
 
Top