How can I use my Logitech webcam in video calls?

Lajto

New Member

Reaction score: 3
Messages: 7

Hi everyone. I want to use my USB Logitech webcam in video calls. :)

The webcam works when using pwcview, but when using Cheese it doesn't ("There was an error playing video from the webcam"). When I try to use it with Firefox (WebRTC services), it never works; appear.in doesn't show anything, and jit.si shows a black screen. When Firefox asks for permission, the webcam is always detected as Webcam C170: Wecbam C170.

It seems that detection is not a problem here. And pwcview proves that it does work in FreeBSD. So... what's the problem?

I installed webcamd like this:
Code:
pkg install multimedia/webcamd multimedia/v4l_compat multimedia/v4l-utils
pw groupmod webcamd -m lajto
chmod 666 /dev/video0


Output of usbconfig:
Code:
ugen0.3: <vendor 0x046d Webcam C170> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON (500mA)


In my /boot/loader.conf I have:
Code:
cuse_load="YES"


In my /etc/rc.conf I have:
Code:
webcamd_enable="YES"


Webcamd detects my webcam without manual intervention needed, as we can see here:
Code:
# webcamd -d ugen0.3 -i 0 -v 0
Webcamd is already running for ugen0.3.0


Thanks in advance. ^^
 

BSDUser

Member

Reaction score: 1
Messages: 21

i have same problem. It is recognized but i don't see video stream......Help us, please!
 

mrusli

New Member

Reaction score: 1
Messages: 16

I am currently using Freebsd 12.2 and right now I am using Logitech C930e.
And I too having the same issues with Cheese that gives the same error as yours.
"There was an error playing video from the webcam."

It seems there is no way to configure any settings that you can change preference of the webcam.

I need to submit freebsd bugs on these right away. See if they can fix the issue.

It works fine in linux distro but there is a problem with freebsd.

I am currently on Luminar desktop environment but not in Gnome Desktop Environment.

It seems that it can't record video and burst.
 
Top