Other Help setting up Slim

joemama

Member

Reaction score: 1
Messages: 28

Hi folks, I'm in the process of slowly configuring my system, and right this minute I'm trying to get a display manager working.

I installed slim about a week ago via packages but I haven't been able to get it working properly.
When I start my system it opens a login screen, but after logging in I'm met with a black screen and get nothing else.

Right now I'm using dwm as my window manager and I'm on FreeBSD 13.
Thanks in advance.
 

Geezer

Aspiring Daemon

Reaction score: 513
Messages: 836

Presumably, before installing slim, you checked to see if you could start your window manager with startx?
 
OP
J

joemama

Member

Reaction score: 1
Messages: 28

Presumably, before installing slim, you checked to see if you could start your window manager with startx?
Yes, this is how I do things right now. I log in from the shell, startx, and then use my computer.
 

Geezer

Aspiring Daemon

Reaction score: 513
Messages: 836

It is a few years since I tried slim. Now I use lightdm, which seems - to me - to be the best DM. Have you tried it?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 13,152
Messages: 39,767

There's nothing you need to configure in slim.conf. The default settings will work just fine[*]. You do need to create an ~/.xinitrc, something like this will do the trick:
Code:
[ -n "$1" ] && [ -x "$1" ] && exec "$1"
SLiM passes the selected DE/WM as an argument. So you need to 'exec' that argument. I added some checks to make sure it's something valid.

[*] You might want to change the current_theme to fbsd and make sure x11-themes/slim-themes is installed.
 
OP
J

joemama

Member

Reaction score: 1
Messages: 28

It is a few years since I tried slim. Now I use lightdm, which seems - to me - to be the best DM. Have you tried it?
I have not, but I’ll look into it.

There's nothing you need to configure in slim.conf. The default settings will work just fine[*]. You do need to create an ~/.xinitrc, something like this will do the trick:
Code:
[ -n "$1" ] && [ -x "$1" ] && exec "$1"
SLiM passes the selected DE/WM as an argument. So you need to 'exec' that argument. I added some checks to make sure it's something valid.

[*] You might want to change the current_theme to fbsd and make sure x11-themes/slim-themes is installed.
When you say “create an .xinitrc” do you mean I need to make one in a new directory somewhere, or that I should add the string you mention into the .xinitrc of my x11 directory?
This may seem like a silly question but I’m trying to be as crystal clear as I can; I’ve learned that assumptions don’t get my very far.
 

eternal_noob

Daemon

Reaction score: 928
Messages: 1,212

When you say “create an .xinitrc” do you mean I need to make one in a new directory somewhere, or that I should add the string you mention into the .xinitrc of my x11 directory?
SirDice said
~/.xinitrc
which means that this file belongs into your home directory. "~" is a shortcut for the current users home.

 
OP
J

joemama

Member

Reaction score: 1
Messages: 28

OP
J

joemama

Member

Reaction score: 1
Messages: 28

There's nothing you need to configure in slim.conf. The default settings will work just fine[*]. You do need to create an ~/.xinitrc, something like this will do the trick:
Code:
[ -n "$1" ] && [ -x "$1" ] && exec "$1"
SLiM passes the selected DE/WM as an argument. So you need to 'exec' that argument. I added some checks to make sure it's something valid.

[*] You might want to change the current_theme to fbsd and make sure x11-themes/slim-themes is installed.
I tried created the ~/.xinitrc with the code you recommended, but all it did for me was stop X from starting when I ran startx. I can't get slim to start at all anymore and the log says

slim: X server could not be started
Giving up.
slim: unable to connect to X server

It's just that on and on for a while in the log with the occaisonal "waiting for X server to begin accepting connections" before logging "giving up".

How can I get the X server to start for slim? Would I set my x server to launch at startup, and if to how do I do that?
Prior to this I could at least get a login screen from slim, but after trying several diffrent things even that stopped working.
 
Top