[help] Dealing with packet loss

Sebastian

Member

Reaction score: 4
Messages: 56

Hello,

I'm using a mac book as client against my freebsd 12 server. I tried to backup a lot of stuff to my server , because I need more space on my mobile device.

That's where the problems starts. I'm trying to copy large files over wifi to my bsd server , but without look. If I'm using a ethernet connection I'm receiving line speed and no packet loss at all. So the cabling in my network should be fine .

I could identify the problem , the bsd server receive a lot out of order packets ~500
#systat --tcp

I don't know why , but the bsd tcp stack can't can't handle this situation. Maybe the client , server or my ap does something wrong....

If I'm trying to copy the same file to a linux box , everything is smooth . I'm pretty sure that there is also packet loss against the linux server , because I'm using the same wifi.

Do I have to tune the default bsd kernel parameter ?

I even tried to limit the bandwith using scp , but without luck.... .

Please share your thoughts ! Thank you !
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,756
Messages: 30,868

If I'm using a ethernet connection I'm receiving line speed and no packet loss at all. So the cabling in my network should be fine .
Your cabling, yes. Your wireless network, not so much.

I don't know why , but the bsd tcp stack can't can't handle this situation.
It's not the TCP/IP stack that's the problem here. Packets out of order and packet loss are symptoms, not the cause.
 
OP
OP
S

Sebastian

Member

Reaction score: 4
Messages: 56

Thanks for your response SirDice

I created two freebsd vm's on the same host via bhyve . Freebsd 11.2 and 12.0 both vm's are seeing the massive out of order packets as well , but they are able to handle them. No connection loss..... even the speed is fine.

On the host itself every time the connection gets lost this counter increases...
netstat -s -p tcp
12358 discarded due to memory problems

I can't image how the vm can handle these packets , but the host is getting out of memory ?

Sure vm's using another nic driver...

EDIT: I could drastically improve the problem with increasing the maxsockbuf .

Code:
kern.ipc.maxsockbuf=16777216
 
Top