HAST + ZFS reboot hang with 'All buffers synced' on 10.2-RELEASE

Theodoros Eracledes

New Member


Messages: 1

Hi (note that that also posted this on the freebsd-questions. I'm new to FreeBSD so please excuse my ignorance)

I have a setup with two SuperMicro machines with an X10SRH motherboards. The O/S is running on ZFS root plus a set of two HGST drives on each machine that are configured as disk0 and disk1 sets replicated with HAST and I created a raidz1 ZFS pool onto those.

The setup works fine otherwise and I can change between primary and backup depending on the CARP status (MASTER/BACKUP) using devd(8).

The issue I have is when I try to reboot the machine that has the zpool mounted (the primary) it gets to "All buffers synced" and it stays there.. because the machine still replies to pings the other node CARP never takes over and I have to power cycle the rebooted primary to get the secondary to take over.

Note that there's no difference if I do a reboot or a
shutdown -r now and if the machine doesn't have the hast zpool mounted or if I disable hast it will reboot fine.

I did found several posts with ZFS issues and "all buffers synced" but it looks like the issue was with upgraded systems from 9.x to 10.x, these are freshly installed 10.2 systems.
https://www.reddit.com/r/freebsd/comments/2mmzzy/101release_restart_problems_anyone/
https://forums.freebsd.org/threads/all-buffers-synced-hang-on-freebsd9.31932/

I did find this post describing that the issue may be due to the shutdown order with hastd stopping before the zfs unmount)
http://tuxnetworks.blogspot.com.cy/2011/12/shutdown-stalls-using-hast-zfs.html

I did add a zfs unmount zpool0 in the precmd in /etc/rc.d/hastd but that didn't help (the ZFS volume didn't unmount)

Any help or guidance will be greatly appreciated

My setup was based on this guide:
http://www.aisecure.net/2012/02/07/hast-freebsd-zfs-with-carp-failover/

Best

Theodoros
 
Top