GUI clock and date problems

web9452

New Member


Messages: 5

#1
When I log in as root and go to the system + clock/date everything is under intensified so I can't change the date or time. Also I can't shut down the computer via the menus: I have to cycle the power switch to shut things down. Any ideas what the problem might be?
 

protocelt

Daemon

Thanks: 406
Messages: 1,253

#3
The problem here may just be that your running the desktop as root. Please don't do that. If you need to elevate privileges to do something use su(1) or sudo(8) or the desktop environments GUI tools for that instead of running the desktop as the root user. Running the desktop as root is a security risk itself and can likely cause file/directory permission issues among other problems when you try to log in as a normal user later on.
 

shepper

Aspiring Daemon

Thanks: 245
Messages: 735

#4
When I log in as root and go to the system + clock/date everything is under intensified so I can't change the date or time. Also I can't shut down the computer via the menus: I have to cycle the power switch to shut things down. Any ideas what the problem might be?
There are two clocks: a system clock and a hardware clock. On startup, the system clock reads the hardware clock and begins time keeping from that reading. On normal shutdown, the system clock resets the hardware clock. Ideally, a brief activation of the power button is supposed to initiate the shutdown sequence but if you press and hold the power button you will abruptly cut power without the system time being applied to the hardware clock. Another, way this can manifest is if the button battery is dead - the hardware clock returns to the initial factory time with each shutdown.

The easiest way to fix this, once you verify your cmos battery is intact, is to enable Network time keeping. Section 28.11 of the Handbook describes howto setup NTP. For my own personal use I like net/openntpd. The code base closely audited, 1/4 the size of net/ntp and still keeps you system within 1-2 seconds of "reality".
 
OP
OP
W

web9452

New Member


Messages: 5

#6
The problem here may just be that your running the desktop as root. Please don't do that. If you need to elevate privileges to do something use su(1) or sudo(8) or the desktop environments GUI tools for that instead of running the desktop as the root user. Running the desktop as root is a security risk itself and can likely cause file/directory permission issues among other problems when you try to log in as a normal user later on.
wWhat is su(1) and sudo(8)?
 

OJ

Daemon

Thanks: 253
Messages: 1,038

#7
iI am using freebsdFreeBSD GUI. on an old HP Vectra. Does that answer your question?
No.

There is no "FreeBSD GUI". You'll have to be using something like Fluxbox or KDE. . . . or are you talking about plain X-windows?

I'm guessing you need to go back to the beginning to explain what you did and what you have. Perhaps re-install.
 
Top