Solved grub-bhyve cannot create VM

I am trying to run linux as a guest on bhyve. I'm following the handbook (21.7) and all of the steps have gone fine up until the point I try to boot the kernel.

Code:
# ls -l
device.map
ubuntu-14.04.4-server-amd64.iso
ubuntu.img
# more device.map
(hd0) ./ubuntu.img
(cd0) ./ubuntu-14.04.4-server-amd64.iso
# grub-bhyve -m device.map -r cd0 -M 2048 ubuntu
Could not create VM ubuntu
Error in initializing VM

I tried using the verbose flag and no more info was printed. I'm pretty sure my CPU is supported (xeon X5670) as the kernel extensions loaded fine. Any help is appreciated! I'm not sure how to start debugging this.
 
Yes...

Code:
$ kldstat
Id Refs Address            Size     Name
 1   26 0xffffffff80200000 179ddb0  kernel
 2    1 0xffffffff8199e000 2f9b00   zfs.ko
 3    2 0xffffffff81c98000 6048     opensolaris.ko
 4    1 0xffffffff81e11000 56aa     fdescfs.ko
 5    1 0xffffffff81e17000 358e     ums.ko
 6    1 0xffffffff81e1b000 1b1baf   vmm.ko
 7    1 0xffffffff81fcd000 55fc     if_tap.ko
 8    1 0xffffffff81fd3000 93b5     if_bridge.ko
 9    1 0xffffffff81fdd000 53fa     bridgestp.ko
10    1 0xffffffff81fe3000 2e96     nmdm.ko
 
I just had the same thought -- I bet that is the culprit. I'll try to head over to the server room this afternoon and see.
 
Back
Top