Solved GPT label problem

Greetings all,

I was labeling drives for a pool, but I have an interesting problem.

gpart show -l ada4
Code:
=>        34  3907029101  ada4  GPT  (1.8T)
          34         222        - free -  (111K)
         256  3907012495     1  zpool_2_2  (1.8T)
  3907012751       16384     9  (null)  (8.0M)

However: zpool status pool
Code:
    NAME               STATE     READ WRITE CKSUM
    pool             ONLINE       0     0     0
      raidz1-0         ONLINE       0     0     0
        gpt/zpool_2_1  ONLINE       0     0     0
        gpt/zpool_2_3  ONLINE       0     0     0
        ada4p1         ONLINE       0     0     0

I have rebooted the machine, exported and imported the pool, but although the other drives' label did change, the ada4 stubbornly refuses to do so.

Any help would be appreciated.

Kindest regards,

M
 
I think, but am not shure, with a a mirror you could, remove ada4p1 from raid with "remove" and later add the same partition using gpt label .
But not with raidz1 as the parity is also on that disk.
Or decision in the beginning can have effect on what is later possible.
Or make a backup and start from scratch...
 
Export pool and import with the -d option.

zpool-import(8)
Code:
             -d dir|device
                     Uses device or searches for devices or files in dir.  The
                     -d option can be specified multiple times.
Example -d dir: zpool import -d /dev/gpt pool

Or each device specified separately -d device: -d /dev/gpt/zpool_2_1 -d ... etc

The device names should not change anymore when exporting and importing again.
 
Top