Solved 'gpart show' columns

Is there any way to specify what is displayed when runnng 'gpart show' ?

What is actually shown in the fourth column? Presumably partition type...Normally it shows something like 'freebsd-ufs', but following a filesystem recovery, all my freebsd partitions show something along the lines of !6a90ba39..... Not sure if this is a UUID.. I also have a number of partitions identified as 'solaris-root'.
Is there some way to change these partition types?
 
What is actually shown in the fourth column?
The partition type.
Code:
     show      Show current partition information for the specified geoms, or
               all geoms if none are specified.  The default output includes
               the logical starting block of each partition, the partition
               size in blocks, the partition index number, the partition type,
               and a human readable partition size.  Block sizes and locations
               are based on the device's Sectorsize as shown by gpart list.

               The show command accepts these options:

               -l          For partitioning schemes that support partition
                           labels, print them instead of partition type.

               -p          Show provider names instead of partition indexes.

               -r          Show raw partition type instead of symbolic name.

Not sure if this is a UUID.
That should be a partition type GUID: https://en.wikipedia.org/wiki/GUID_Partition_Table#Partition_type_GUIDs

I also have a number of partitions identified as 'solaris-root'.
That seems strange. Especially if you're sure that was freebsd-ufs before.

But, you mentioned a file system recovery? Did the original disk have bad sectors? It may just have been reading bad data and tried to interpret the result.

Is there some way to change these partition types?
Contrary to what you might think, the actual file system in that partition doesn't depend on the partition type. I can create a freebsd-ufs partition and format it with FAT32 without issue. Obviously I don't recommend doing that because it's confusing as heck, but there's technically nothing stopping me from doing that.

The actual partition type is fairly irrelevant. What's way more important are the start and end blocks. But if the GUID got mangled due to read errors, there's a good chance the start and end positions are incorrect too.
 
Code:
root@EMTEC:~ # gpart show ada0
=>       34  976773101  ada0  GPT  (466G)
         34       2014        - free -  (1.0M)
       2048   96065544     1  linux-data  (46G)
   96067592      65536     2  efi  (32M)
   96133128     114688     3  !6a90ba39-1dd2-11b2-96a6-080020736631  (56M)
   96247816   10485760     4  solaris-root  (5.0G)
  106733576    4194304     5  !6a90ba39-1dd2-11b2-96a6-080020736631  (2.0G)
  110927880  251658240     6  solaris-root  (120G)
  362586120       2040        - free -  (1.0M)
  362588160   41943040     7  linux-data  (20G)
  404531200   41943040     8  linux-data  (20G)
  446474240   20971520     9  linux-data  (10G)
  467445760    4194304    10  linux-data  (2.0G)
  471640064   20971520    11  linux-data  (10G)
  492611584    2097152    12  linux-data  (1.0G)
  494708736    4194304    13  linux-data  (2.0G)
  498903040   20971520    14  linux-data  (10G)
  519874560   20971520    15  linux-data  (10G)
  540846080   41943040    16  !6a90ba39-1dd2-11b2-96a6-080020736631  (20G)
  582789120   41943040    17  solaris-root  (20G)
  624732160   20971520    18  !6a90ba39-1dd2-11b2-96a6-080020736631  (10G)
  645703680   20971520    19  !6a90ba39-1dd2-11b2-96a6-080020736631  (10G)
  666675200  251658240    20  !6a90ba39-1dd2-11b2-96a6-080020736631  (120G)
  918333440   58439688    21  solaris-root  (28G)
  976773128          7        - free -  (3.5K)

ada0p3 contains mfsBSD and boots ok. I'm still investigating the rest.

The system was recovered thanks to testdisk, so maybe it named the partition types this way.
It seems that I can rename the partition types using

gpart modify -i 3 -t freebsd-ufs ada0
 
Back
Top