Got a mouse arrow and it moves, what next? [ WAYLAND+KDE ]

Here's what I tried to start kde5plasma on wayland:

#! /bin/sh
export XDG_SESSION_TYPE=wayland
ck-launch-session dbus-run-session /usr/local/bin/startplasma-wayland
#ck-launch-session dbus-run-session /usr/local/bin/

And here's a small snippet of the running processes
user       1441  90.2  0.4  391456 117444 v0  R+   23:43    1:12.67 kwin_wayland --wayland_fd 4 --xwayland /usr/local/l
user       1442  47.3  0.0   23336   8572 v0  S+   23:43    0:38.23 /usr/local/bin/Xwayland -displayfd 43 -rootless -wm
user       1429   0.0  0.0   13624   2988 v0  I+   23:43    0:00.00 sh
user       1430   0.0  0.0   16924   3912 v0  I+   23:43    0:00.01 ck-launch-session dbus-run-session /usr/local/bin/s
user       1437   0.0  0.0   13544   2864 v0  I+   23:43    0:00.00 dbus-run-session /usr/local/bin/startplasma-wayland
user       1438   0.0  0.0   14044   3456 v0  I+   23:43    0:00.07 dbus-daemon --nofork --print-address 4 --session
user       1439   0.0  0.1   85604  19252 v0  I+   23:43    0:00.12 /usr/local/bin/startplasma-wayland
user       1440   0.0  0.0   14052   3020 v0  I+   23:43    0:00.00 /usr/local/bin/kwin_wayland_wrapper --xwayland /usr
I get a mouse arrow and I can move it around but no menus appear of clicking, no KDE desktop or an taskbar or anything.. it's something like Xorg without twm 😬

What shall I do next?
Not helpful!
I had gone through multiple posts including the one you shared before posting this query.
I am using the quarterly pkgs and am on FBSD 13R, sddm is enabled, already gave the process list, i915kms loaded, dbus is enabled, touchpad works fine.
What's missing? Any additional config? Improper binaries of kde or some other dependency? Am I calling something the wrong way? Do I need to be on 14CURRENT?

I just need to know which of the duck (daemon/beastie??) is out of line.
  • Boot to a text console,
  • Log in as a regular user,
  • Run /usr/local/bin/
running the plasma-wayland session from sddm won't work
I am using the quarterly pkgs
Quarterly don't work that well... You need to switch to 'Latest' using /usr/local/etc/pkg.conf. After that, according to Adriaan DeGroot's blog entry,

The “enjoy” part is only if you have the latest versions of packages: plasma5-plasma-workspace-5.21.4_2 and plasma5-kwin-5.21.4_4 or newer than that.
When I was compiling, I watched that my versions fit. I tried using 'quarterly' myself - and had a cursor that didn't do anything...
Well, I switched to quarterly from latest as per ADG's advise and that's how I got 5.21.
Without changing the pkg.conf I was served plasma5.20.5

Secondly, I have the script and if I run it as is, I didn't even reach the GUI screen. The script can't be executed as is.
But I will try your advise and switch back to Latest and see how it goes. Thanks everyone.