Google Earth, version `GLIBCXX_3.4.9' not found

DavidMarec

Member

Reaction score: 18
Messages: 74

Bonjour,


I am trying to run google-earth on a FreeBSD 7.2 box.

But, while the installation step was successfull, i get the following error when I launch the software.

Code:
david:~>googleearth
./googleearth-bin: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./libgoogleearth_lib.so)
./googleearth-bin: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./libbase.so)
Upgrading linux_base-f7 to linux_base-f8 do not solve the issue.

any idea to get the right version of glibc++ ?
 

ale

Daemon

Reaction score: 166
Messages: 1,059

What is the output of sysctl compat.linux.osrelease?
 
OP
DavidMarec

DavidMarec

Member

Reaction score: 18
Messages: 74

Nicholas said:
Same problem (linux_base-f8)
sysctl compat.linux.osrelease is same
Guess that google-earth is not the only linux port that fails running with this stuff.
 

ale

Daemon

Reaction score: 166
Messages: 1,059

For curiosity I've tested it on fc4 too.
Slightly different message, but same result.
Maybe it's better asking the maintainer.
 

Nicholas

Member

Reaction score: 6
Messages: 59

DavidMarec said:
Guess that google-earth is not the only linux port that fails running with this stuff.
all other linux ports work fine (i.e. flashplugin-10 and Skype:) )
 
OP
DavidMarec

DavidMarec

Member

Reaction score: 18
Messages: 74

Nicholas said:
all other linux ports work fine (i.e. flashplugin-10 and Skype:) )
Actually, upgrading to linux_base-f10 has solved the issue.
But, while the GUI is displayed correctly, i get a black screen instead of the map drawings.
 

Nicholas

Member

Reaction score: 6
Messages: 59

But, while the GUI is displayed correctly, i get a black screen instead of the map drawings.
AFAIK, 7.x doesn't support linux_base-f10 completely.
 

eugenevdm

New Member


Messages: 2

Just for interest sake, I have Ubuntu 9.04 64-bit and I get exactly the same error:

Code:
./googleearth-bin: ./libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./libgoogleearth_lib.so)
./googleearth-bin: ./libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./libbase.so)
Output of uname -a:
Code:
"Linux eugene-work 2.6.28-15-generic #49-Ubuntu SMP Tue Aug 18 19:25:34 UTC 2009 x86_64 GNU/Linux"
 
Top