Gnome3 unusable (lags) on Matebook X (amdgpu)

ruthr

Member

Reaction score: 11
Messages: 68

Greeting

Did anyone have a problem similar to mine with Gnome3. Namely, when starting, I have a big lag on loading that never goes away. If i switch betwen consoles only then is it seen that Gnome3 "works" . Other windows managers works OK (i try Mate/Xfce/Kde and i dont see any problem). HW acceleration works OK. Have tryed both 13-RELEASE and 14-current and same problem on both.
Does anyone have any idea what it might be?

Here are pictures from MATE (glxgears) that works OK and Gnome3 loading screen (i need to swith console to get some activity from Gnome3) and glxgears (same thing .. need to switch between consoles to get some activity).
There is also visible droping of FPS when running glxgears on Gnome3 (lags and waiting)

https://i.postimg.cc/9F6zDk3r/20210420-112811.jpg
https://i.postimg.cc/rpcmJtwT/20210420-112823.jpg
https://i.postimg.cc/SNCYf4fW/20210420-112842.jpg
https://i.postimg.cc/B6jBqy9M/20210420-113439.jpg


https://i.postimg.cc/MT1Jr9Pr/20210420-113120.jpg
 

Attachments

  • glxinfo.txt
    146.3 KB · Views: 47
  • glxinfo.txt
    146.3 KB · Views: 50
  • Xorg.txt
    22 KB · Views: 71
  • glxinfo.txt
    146.3 KB · Views: 42

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 13,119
Messages: 39,712

OP
R

ruthr

Member

Reaction score: 11
Messages: 68

Code:
 Current Operating System: FreeBSD pila 14.0-CURRENT FreeBSD 14.0-CURRENT #0 main-n246078-14d0cd7225e: Thu Apr 15 08:36:43 UTC 2021     root@releng1.nyi.freebsd.org:/usr/obj/usr/src/amd64.amd64/sys/GENERIC amd64

Topics about unsupported FreeBSD versions


Stick to 13.0-RELEASE.

Do you have graphics/drm-kmod installed?

It is same problem on 13.0-RELEASE and 14-CURRENTand now im stick on 14.

Yes i have graphics/drm-kmod installed and acceleration works on all other window managers. Only problem i have with GNOME3 and Cinammon (accelerated) .
 
OP
R

ruthr

Member

Reaction score: 11
Messages: 68

If you have not already done so, I encourage you to please leave a comment so that the bug gets more attention etc...

Thank you.


Hi . i manage to find workaround for my problem .. can u try this in xorg.conf

Code:
Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "Accel"                  # [<bool>]
        Option     "SWcursor"   "true"            # [<bool>]
        #Option     "EnablePageFlip"         # [<bool>]
        #Option     "SubPixelOrder"          # [<str>]
        #Option     "ZaphodHeads"            # <str>
        #Option     "AccelMethod"            # <str>
        ##Option     "DRI3"    "1"               # [<bool>]
        Option     "DRI" "2"                   # <i>
        #Option     "ShadowPrimary"          # [<bool>]
        Option     "TearFree"  "true"             # [<bool>]
        #Option     "DeleteUnusedDP12Displays"     # [<bool>]
        #Option     "VariableRefresh"        # [<bool>]
    Identifier  "Card0"
    Driver      "amdgpu"
    BusID       "PCI:3:0:0"
EndSection

disable DRI3 and enable to use DRI2 ..

this fix my lagggis GNOME3


https://i.postimg.cc/KjwfQ8HZ/Screenshot-from-2021-04-27-13-37-25.png
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 13,119
Messages: 39,712

It is same problem on 13.0-RELEASE and 14-CURRENTand now im stick on 14.
Before making this decision you should know that 14-CURRENT is an unsupported development version. I strongly urge you to just go with 13.0-RELEASE. Besides being a supported version, it's much easier to update with freebsd-update(8). Both -CURRENT and -STABLE can only be updated/upgraded by building from source.

Topics about unsupported FreeBSD versions
 

Alexander88207

Aspiring Daemon

Reaction score: 561
Messages: 770

Hi . i manage to find workaround for my problem .. can u try this in xorg.conf

Code:
Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "Accel"                  # [<bool>]
        Option     "SWcursor"   "true"            # [<bool>]
        #Option     "EnablePageFlip"         # [<bool>]
        #Option     "SubPixelOrder"          # [<str>]
        #Option     "ZaphodHeads"            # <str>
        #Option     "AccelMethod"            # <str>
        ##Option     "DRI3"    "1"               # [<bool>]
        Option     "DRI" "2"                   # <i>
        #Option     "ShadowPrimary"          # [<bool>]
        Option     "TearFree"  "true"             # [<bool>]
        #Option     "DeleteUnusedDP12Displays"     # [<bool>]
        #Option     "VariableRefresh"        # [<bool>]
    Identifier  "Card0"
    Driver      "amdgpu"
    BusID       "PCI:3:0:0"
EndSection

disable DRI3 and enable to use DRI2 ..

this fix my lagggis GNOME3


https://i.postimg.cc/KjwfQ8HZ/Screenshot-from-2021-04-27-13-37-25.png
Thanks for the hint, I'll try it out right away at home :)

I hope that I do not see too big a drop in performance when playing.
 

ZKRiNG

New Member

Reaction score: 2
Messages: 17

Im having the same issue with nvidia card. With other WMs all works super nice, with gnome its a nightmare.
 

eternal_noob

Daemon

Reaction score: 901
Messages: 1,188

gnome is a nightmare.
Fixed it for you.

Seriously, Gnome is a pile of crap, you're better off using another desktop.

Torvalds abandoned GNOME for a while after the release of GNOME 3.0, saying, "The developers have apparently decided that it's 'too complicated' to actually do real work on your desktop, and have decided to make it really annoying to do".
 
Top