Solved Gnome3, how to disable ibus-daemon?

dr-mdr

Member

Thanks: 1
Messages: 35

#1
Gnome3 , how to disable ibus-daemon?

Code:
sudo killall ibus-daemon
ibus-daemon will be start again after kill

Code:
gsettings set org.gnome.settings-daemon.plugins.keyboard active false
nonthings happen after gsettings

how can I do ?

I want to disable ibus-daemon!
 

scottro

Daemon

Thanks: 427
Messages: 1,259

#2
I know that with openbox, I installed it and didn't want it running each time I started X. (This was in Linux.) There was, in Linux, an /etc/xdg/autostart and in there something like im-settings-start. (Or something similar). I renamed it to whateveritwascalled-orig and then it no longer started when I started X.

Gnome is a desktop environment, as opposed to a window manager, so it might be harder to find its start up scripts, but it's worth looking for that file--in FreeBSD, it would probably be in /usr/local/etc/xdg, but I'm not on a BSD machine right now.
 
OP
OP
dr-mdr

dr-mdr

Member

Thanks: 1
Messages: 35

#3
First of all , thank you for help.
Code:
cd /usr/local/etc/xdg/autostart
rm ibus.desktop
reboot
After reboot, ibus-daemon still running when I run startx (Gnome 3.14).
 

protocelt

Daemon

Thanks: 406
Messages: 1,253

#5
If I remember correctly ibus is integrated into GNOME, is required, and disabling it through any available configuration method was removed. It makes sense then that if you kill the daemon it will just be restarted by GNOME.
 
Top