• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

GNOME2 env. seahorse agent Gconf error

FumiakiSakaomoto

Member


Messages: 22

#1
Hi,

Would someone tell me how to solve this error message on /var/log/auth.log?
Code:
Dec  8 06:39:34 fumiaki seahorse-agent[2234]: GConf error:   Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: Failed to get connection to session: Error connecting: Connection refused)
on my machine: /etc/rc.conf is shown below:
Code:
hostname="username"
keymap="jp.106.kbd"
ifconfig_bfe0="DHCP"
ifconfig_bfe0_ipv6="inet6 accept_rtadv"
sshd_enable="YES"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"
dbus_enable="YES"
hald_enable="YES"
polkitd_enable="YES"
gdm_enablle="YSE"
gnome_enable="YES"
linux_enable="YES"
I installed x11/gnome2, x11/gnome2-fifth-toe, and x11/xorg by Ports install.

Again, would someone help?
 

cpm@

Moderator
Staff member
Moderator
Developer

Thanks: 890
Messages: 2,100

#2
You should correct syntax in /etc/rc.conf
Code:
gdm_enable="YES"
Do not panic, this message typically occurs, when logging out of GNOME, and does not cause any functionality loss ;)
Code:
Dec 8 06:39:34 fumiaki seahorse-agent[2234]: GConf error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Error connecting: Connection refused)
http://freebsd.1045724.n5.nabble.com/gconf-error-td3861445.html.
 

FumiakiSakaomoto

Member


Messages: 22

#3
You should correct syntax in /etc/rc.conf

Code:
gdm_enable="YES"
Do not panic, this message typically occurs, when logging out of GNOME, and does not cause any functionality loss

Code:
Dec 8 06:39:34 fumiaki seahorse-agent[2234]: GConf error: Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http:/
/projects.gnome.org/gconf/ for information. (Details - 1: Failed to get connection to session: Error connecting: Connection refused)
http://freebsd.1045724.n5.nabble.com...td3861445.html.
Thank you,

I corrected syntax in /etc/rc.conf
Then reboot, but that message still occurs, but as you say maybe it does not cause any functionality loss.
 

cpm@

Moderator
Staff member
Moderator
Developer

Thanks: 890
Messages: 2,100

#4
Show output to see the ownership of that directory:
# ls -l .dbus/session-bus

According this bug, can be fixed changing owner .dbus directory

Using chown(8), type:
# chown -R username ~/.dbus

Try post your results.
 

FumiakiSakaomoto

Member


Messages: 22

#5
Thank you for the attention!
But..
I tried:
fumiaki# ls -l .dbus/session-bus
total 8
-rw-r--r-- 1 fumiaki fumiaki 463 12月 4 17:26 16dcc6c4e70be9def237c82800001134-0
-rw-r--r-- 1 fumiaki fumiaki 459 12月 10 11:29 d3b3b8c526daede2eb9182e800002234-0
fumiaki# chown -R fumiaki ~/.dbus
fumiaki# ls -l .dbus/session-bus
total 8
-rw-r--r-- 1 fumiaki fumiaki 463 12月 4 17:26 16dcc6c4e70be9def237c82800001134-0
-rw-r--r-- 1 fumiaki fumiaki 459 12月 10 11:29 d3b3b8c526daede2eb9182e800002234-0
It seems nothing changed...
Would you please help something more?
 

FumiakiSakaomoto

Member


Messages: 22

#7
Thanks again! But still seahorse-agent Gconf error remains.
I did as you told me, disabled x11/gdm by gdm_enable="NO" on /var/rc.conf and added the code on ~/.xinitrc. But nothing changed.
Starting gdm
still remained
then I tried for disabling x11/gdm completely as follows.
fumiaki# cd /usr/ports/x11/gdm
fumiaki# ls
Makefile files pkg-install pkg-plist
distinfo pkg-descr pkg-message
fumiaki# make clean
===> Cleaning for gdm-2.30.5_6
fumiaki# make deinstall clean
===> Deinstalling for x11/gdm
===> Deinstalling gdm-2.30.5_6
pkg_delete: package 'gdm-2.30.5_6' is required by these other packages
and may not be deinstalled (but I'll delete it anyway):
gnome2-2.32.1_4
pkg_delete: unable to completely remove directory '/usr/local/share/gdm/autostart/LoginWindow'
pkg_delete: unable to completely remove directory '/usr/local/share/gdm/autostart'
pkg_delete: unable to completely remove directory '/usr/local/share/gdm'
==> You should manually remove the "gdm" user.
pkg_delete: couldn't entirely delete package `gdm-2.30.5_6'
(perhaps the packing list is incorrectly specified?)
===> Cleaning for gdm-2.30.5_6
then
Code:
#startx
This destroyed normal start of gnome.
So I reinstalled the x11/gdm and then recovered but still seahorse-agent error remained.
I thought this problem caused by the Japanese language environment of /usr/ports/japanese/scim-anthy.
~/.xinitrc was/is as follows.
export LANG=ja_JP.UTF-8
export LC_CTYPE=ja_JP.UTF-8
export XMODIFIERS='@im=SCIM'
export GTK_IM_MODULE=scim
echo '*inputMethod: SCIM' | xrdb -merge
scim -d
sleep 3
ck-launch-session dbus-launch gnome-session
So I tried except ck-launch-session dbus-launch gnome-session, added # at the beginning of each line then disabled Japanese environment.
But still seahorse-agent error remains as I showed at the first mention.
it seems Japanese environment was not the cause??

Actually, my PC is i686 and 512MB memory only (FreeBSD-9.0-Release-i386).
Now I think this low spec doesn't afford doing normal gnome2 action...

Do you have some ideas else for this problem?
Would you please give me advises?
 

FumiakiSakaomoto

Member


Messages: 22

#8
Sorry, I am a little confused maybe....
Before I re-configured the ~/.xinitrc for Japanese environment.
It seems no seahorse-agent error on /var/log/auth.log?
Dec 11 16:30:35 fumiaki polkitd(authority=local): Unregistered Authentication Ag
ent for unix-session:/org/freedesktop/ConsoleKit/Session2 (system bus name :1.36
Dec 11 16:30:35 fumiaki polkitd(authority=local): Unregistered Authentication Ag
ent for unix-session:/org/freedesktop/ConsoleKit/Session2 (system bus name :1.36
, object path /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (di
les; type="method_call", sender=":1.44" (uid=1001 pid=2281 comm="nautilus ") int
Dec 11 16:37:33 fumiaki dbus[1829]: [system] Rejected send message, 2 matched ru
les; type="method_call", sender=":1.44" (uid=1001 pid=2281 comm="nautilus ") int
\xe3M-^A
Dec 11 16:30:35 fumiaki polkitd(authority=local): Unregistered Authentication Ag
ent for unix-session:/org/freedesktop/ConsoleKit/Session2 (system bus name :1.36
, object path /org/gnome/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (di
les; type="method_call", sender=":1.44" (uid=1001 pid=2281 comm="nautilus ") int
Dec 11 15:45:54 fumiaki dbus[1829]: [system] Rejected send message, 2 matched ru
Dec 11 16:30:35 fumiaki polkitd(authority=local): Unregistered Authentication Ag
ent for unix-session:/org/freedesktop/ConsoleKit/Session2 (system bus name :1.36
^CM-^M\xe3M-^CM-^C\xe3M-^CM-^H\xe3M-^C\xaf\xe3M-^C\xbc\xe3M-^B\xaf\xe3M-^BM-^R\x
e6M-^\M- \xe5M- \xb9\xe3M-^A\xab\xe3M-^AM-^W\xe3M-^A\xa6\xe3M-^AM-^D\xe3M
-^A\xaa\xe3M-^AM-^D\xe3M-^@M-^A\xe3M-^AM-^B\xe3M-^BM-^K\xe3M-^AM-^D\xe3M-^A\xaf\
Dec 11 16:32:11 fumiaki polkitd(authority=local): Registered Authentication Agen
Dec 11 16:37:15 fumiaki gnome-keyring-daemon[2219]: couldn't allocate secure mem
Dec 11 16:37:53 fumiaki su: fumiaki to root on /dev/pts/0
Dec 11 16:39:57 fumiaki sshd[2009]: Server listening on :: port 22.
Dec 11 16:39:57 fumiaki sshd[2009]: Server listening on 0.0.0.0 port 22.
Dec 11 16:40:19 fumiaki polkitd(authority=local): Registered Authentication Agen
t for unix-session:/org/freedesktop/ConsoleKit/Session1 (system bus name :1.18 [
/usr/local/libexec/polkit-gnome-authentication-agent-1], object path /org/gnome/
PolicyKit1/AuthenticationAgent, locale )
Dec 11 16:40:50 fumiaki gnome-keyring-daemon[2204]: couldn't allocate secure mem
ory to keep passwords and or keys from being written to the disk
Dec 11 16:40:58 fumiaki polkitd(authority=local): Registered Authentication Agen
t for unix-session:/org/freedesktop/ConsoleKit/Session2 (system bus name :1.35 [
/usr/local/libexec/polkit-gnome-authentication-agent-1], object path /org/gnome/
PolicyKit1/AuthenticationAgent, locale ja_JP.UTF-8)
Dec 11 16:41:07 fumiaki dbus[1829]: [system] Rejected send message, 2 matched ru
les; type="method_call", sender=":1.45" (uid=1001 pid=2266 comm="nautilus ") int
erface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" re
quested_reply="0" destination=":1.1" (uid=0 pid=1851 comm="/usr/local/sbin/conso
le-kit-daemon --no-daemon ")
>>>>
Dec 11 16:41:55 fumiaki shutdown: reboot by root:
I don't understand it well...but if Japanese environment causes the "seahorse-agent Gconf error"?

Would you please help?
 

FumiakiSakaomoto

Member


Messages: 22

#9
I did make ~/.xinitrc simpler.
~/.xinitrc:
Code:
export LANG="ja_JP.UTF-8"
export XMODIFIERS=@im=SCIM
scim -d 
ck-launch-session dbus-launch gnome-session
Yet still seahorse-agent Gconf error remains...
 

cpm@

Moderator
Staff member
Moderator
Developer

Thanks: 890
Messages: 2,100

#10
Make these changes that will explain below:

Modify .xinitrc like this:
Code:
ck-launch-session dbus-launch gnome-session
Add in your shell configuration, I will use as an example csh(1), but you must modify it according to the type of shell you use:
In this case in ~/.cshrc
Code:
setenv XMODIFIERS @im=SCIM
setenv GT_IM_MODULE scim
setenv QT_IM_MODULE scim
setenv LC_ALL ja_JP.UTF-8
If you use bash(1), add in ~/.bashrc:
Code:
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE="scim"
export QT_IM_MODULE="scim"
export LC_CTYPE=ja_JP.UTF-8
In all cases, add in ~/.xsession the following line:
Code:
scim -d
 

FumiakiSakaomoto

Member


Messages: 22

#11
Thanks indeed!
I modified ~/.xinitrc, ~/.cshrc, and ~/.xsession as you told me.
and repeated reboot and confirming the log some times.

But still seahorse-agent Gconf error occurs at the times of shutting down...
 

cpm@

Moderator
Staff member
Moderator
Developer

Thanks: 890
Messages: 2,100

#12
Add in /etc/rc.conf to clear /tmp at startup:
Code:
clear_tmp_enable="YES"
At the end, you can disable console notification, at least you can stop receiving this output from console.

Comment this line in /etc/syslog.conf:
[CMD=]#*.err;kern.debug;auth.notice;mail.crit /dev/console[/CMD]

But it will not stop kernel generated messages like device timeouts, hardware errors, lock warnings etc, as they are actually printed by the kernel not syslog.
 

EW1

New Member

Thanks: 1
Messages: 5

#16
Thank you, cpu82.

The seahorse gconf error wasn't caused by FumiakiSakaomoto-san's Japanese language setup, since I had the same problem, but by a hidden file left over from an earlier session in the /tmp directory where the sockets and things are kept during a session.
 
Top