Gnome won't start

knightjp

Active Member

Reaction score: 27
Messages: 167

I'm trying to install FreeBSD 11. I followed the tutorial in this video below correctly and it just keeps loading the command like alone. It say that gdm started, but nothing.

 

good-beastie

Member

Reaction score: 10
Messages: 44

Hello, try this command pkg info -aD | grep procfs and look for procfs. If so, edit /etc/fstab with
Code:
proc    /proc           procfs          rw      0       0
Also,
Code:
gdm_enable="YES"
may not be needed in /etc/rc.conf, use
Code:
gnome_enable="YES"
instead. Handbook: 5.7. Desktop Environments.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,763
Messages: 30,893

Forget about Gnome and GDM, you need to make sure Xorg actually works. Then you can move to Gnome/GDM. At the console (using a normal user account) run startx. If that fails post your /var/log/Xorg.0.log to Pastebin (or a similar service), misc/pastebinit is quite useful for this.
 
OP
OP
knightjp

knightjp

Active Member

Reaction score: 27
Messages: 167

I've narrowed the culprit to Xorg. It does not install the xf86-video-fbdev pkg. I look for it and it does not seem available as package at all. Installing it as a port does not seem to work. My only chance now is to remove Xorg completely and try to install it using the ports. Did that once and it look literally like 3 hours to install. If I cannot remove Xorg, then I am going to have to do a complete reinstall and install Xorg via ports.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,763
Messages: 30,893

Post your Xorg.0.log. That will tell us what's being detected, what hardware you have etc.
 
OP
OP
knightjp

knightjp

Active Member

Reaction score: 27
Messages: 167

Sorry... I could not post it as a text document. I'm new to BSD and terminal commands in general. So this all in the learning curve for me.

Perhaps these pictures should give you an idea of what I'm dealing with.


(Mod: Removed unreadable pictures)
 
Last edited by a moderator:

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,763
Messages: 30,893

Please, just install misc/pastebinit and do cat /var/log/Xorg.0.log | pastebinit. Then post the URL it shows you.
 

tobik@

Daemon
Developer

Reaction score: 1,378
Messages: 1,909

Sorry, but misc/pastebinit's default service is currently broken and won't show the URL correctly. Try again with cat /var/log/Xorg.0.log | pastebinit -b sprunge.us
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,763
Messages: 30,893

Much better. This is an error:
Code:
[    61.525] (EE) module ABI major version (20) doesn't match the server's version (19)
[    61.525] (II) UnloadModule: "vesa"
[    61.525] (II) Unloading vesa
[    61.525] (EE) Failed to load module "vesa" (module requirement mismatch, 0)
Looks like you have some discrepancy with the versions you installed. How did you install x11/xorg?

Can you also tells us what hardware you have? If it's a laptop please provide the model number.
 
OP
OP
knightjp

knightjp

Active Member

Reaction score: 27
Messages: 167

Installing Xorg was a painful 6 hour process. I can't even begin to describe the issues. Basically what you are seeing here is the 10th installation of FreeBSD since the start of this thread. I'm out of time right now so I'll get into that later. What I would like to know is if there is anything that I can do to fix the current installation without having to go through the 6 hour process of Xorg again.
The strange thing is that it was just loading Gnome3 a minute ago perfectly fine and then after another reboot, this...
All I did was "adduser"

The laptop that I'm trying to install it on is an ASUS X551M. Its an old laptop.. Linux installs on this machine just fine without any hitch.
 
OP
OP
knightjp

knightjp

Active Member

Reaction score: 27
Messages: 167

I do apologize for my last reply.

Now that I have some free time. I'll get into how I installed Xorg.
I didn't expect FreeBSD to be such a problem to install on the ASUS X551M. I have another HP (older machine) and it installed everything without a hitch. As I stated earlier, I had no issues installing Linux on the machine.

http://sprunge.us/jfAE
The installation posted on above link is the 10th one that I have been doing since I started this thread. I know what the problem is. The problem lies with Xorg-Drivers.
If I use the pkg system to install Xorg, Xorg-Drivers does not the critical xf86-video-fbdev driver that is required by the ASUS.
Using the ports system takes quite a lot of time. I recall spending an entire evening trying to install it. But that too, if I try to install Xorg through the ports, I have to do it without updating the ports tree. If I update the ports tree, and I do "cd /usr/ports/x11-drivers/xorg-drivers/ & then "make config"; I will not see "fbdev" as an option to select and install.

If I install try to install the xf86-video-fbdev using the pkg, it says "package is not available"
I could install it using the ports "cd /usr/ports/x11-drivers/xf86-video-fbdev" & "make install clean", but that still gives me an error if I use "startx". Basically looking through the file, it does not recognize that the fbdev driver is installed on the machine; even after a reboot.

So my only option is to start from scratch and try to install Xorg using the ports system; without first updating the ports tree and you would normally do.

However in this last install, while using the ports to install Xorg, I ran into a whole load of interference. These issues were not there when I installed Xorg the first time through the ports. The process halted stating that some ports /dependencies were "vunerable". What I would do is "pkg install (dependency) and then "make reinstall clean" for Xorg and then that would proceed as normal. I guess that is what has reflected on the link.

So my question is how do I fix this installation as it is now?
Or if I have to start from scratch again, how do I install Xorg via the package and install the xf86-video-fbdev port/package and have it work when I use "startx"

Mind you this is all before I install Gnome3.
 

tingo

Daemon

Reaction score: 399
Messages: 2,060

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,763
Messages: 30,893

The fbdev will always be probed by Xorg. It always fails but this is not an issue. What is an issue though is that Bay Trail GPUs are not supported. Not yet at least. The vesa(4) driver should work but won't provide 2D/3D acceleration.
 
OP
OP
knightjp

knightjp

Active Member

Reaction score: 27
Messages: 167

The intel driver is also installed at the same time; as is the vesa driver. But if there is no fbdev installed, if you type "startx", it will not work. Fbdev has to be installed along with Xorg using the ports.

But that doesn't seem likely to happen now considering; if I attempt to install it using the ports method now, I will surely get errors because of the other dependencies.

So what is the way forward from where I am now?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,763
Messages: 30,893

So what is the way forward from where I am now?
Just use the packages. There's no reason to use the ports if you're going to use the default settings any way.
 
OP
OP
knightjp

knightjp

Active Member

Reaction score: 27
Messages: 167

Thanks for the advice.. but what about my machine's dependency on fbdev?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,763
Messages: 30,893

Forget it. It will not depend on it (it can't, the port/package doesn't exist any more).
 

tingo

Daemon

Reaction score: 399
Messages: 2,060

Ok, you didn't install xf86-video-intel, based on these lines:
Code:
[ 22029.279] (II) LoadModule: "intel"
[ 22029.280] (WW) Warning, couldn't open module intel
[ 22029.280] (II) UnloadModule: "intel"
[ 22029.281] (II) Unloading intel
[ 22029.281] (EE) Failed to load module "intel" (module does not exist, 0)
which driver are you trying to use? If you are trying to use the vesa driver, try to create the file /usr/local/etc/X11/xorg.conf.d/driver-vesa.conf with the following contents
Code:
Section "Device"
        Identifier "Card0"
        Driver     "vesa"
EndSection
It shouldn't be needed, and it might not change anything, but it is quick and easy to try, and if it works...
 
OP
OP
knightjp

knightjp

Active Member

Reaction score: 27
Messages: 167

If it is an Intel card, would be best to use the Intel driver. Am I right..

so my next step would be
Code:
pkg install xf86-video-intel
What is the next step after installing the driver?
 

tingo

Daemon

Reaction score: 399
Messages: 2,060

If it is supported by the intel driver, yes.
Try it, if it works your a happy camper.
If not, you are back to reporting errors again.
 
OP
OP
knightjp

knightjp

Active Member

Reaction score: 27
Messages: 167

Sorry it took a while for me to get back to this issue. I was away in Indonesia for a couple of days.

Installed Intel... this is what the log shows now..

http://sprunge.us/LDPd
 

monwarez

Member

Reaction score: 9
Messages: 26

First I don't see why there is the need of
Code:
hald_enable="YES"
in /etc/rc.conf since hald is deprecated and not by default in x11-servers/xorg-server
Second if the intel driver is supported, there should be in /etc/rc.conf
Code:
kld_list="i915kms"
But before doing that, try login first, and load intel kms drivers
kldload i915kms as root, and then startx as regular user.
If it is working then you can add i915kms in the kld_list .
Note that you may need to add your user to the video group to be able of using 3D application.
 
Top