GNOME starts in black

jojopara

New Member

Reaction score: 1
Messages: 16

Hello,
I have installed Gnome and it worked nicely for a few restarts. There is only black screen now in the VM.
Thank you in advance.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,691
Messages: 39,287

What version of FreeBSD? What type of graphics card does the machine have? How is Xorg configured?
 
OP
jojopara

jojopara

New Member

Reaction score: 1
Messages: 16

FreeBSD-12.0-RELEASE-amd64-bootonly

It is installed in Virtualbox in:

██████████████████ ████████ jojo@jojo
██████████████████ ████████ OS: Manjaro 18.1.0 Juhraya
██████████████████ ████████ Kernel: x86_64 Linux 5.2.11-1-MANJARO
██████████████████ ████████ Uptime: 44m
████████ ████████ Packages: 1349
████████ ████████ ████████ Shell: bash 5.0.9
████████ ████████ ████████ Resolution: 2560x1440
████████ ████████ ████████ DE: Cinnamon 4.2.4
████████ ████████ ████████ WM: Muffin
████████ ████████ ████████ WM Theme: Mint-Y-Dark-Teal (Mint-Y)
████████ ████████ ████████ GTK Theme: Mint-Y-Dark-Teal [GTK2/3]
████████ ████████ ████████ Icon Theme: Papirus-Adapta-Nokto-Maia
████████ ████████ ████████ Font: Cantarell 14
████████ ████████ ████████ Disk: 8,7T / 12T (79%)
CPU: Intel Core i7-8700K @ 12x 4.7GHz [34.0°C]
GPU: Mesa DRI Intel(R) UHD Graphics 630 (Coffeelake 3x8 GT2)
RAM: 3738MiB / 64279MiB

I do not how to configure Xorg; I have simply in stalled it.
 
OP
jojopara

jojopara

New Member

Reaction score: 1
Messages: 16

SirDice,

Thank you for your help!

I did " emulators/virtualbox-ose-additions " and vboxguest_enable="YES" vboxservice_enable="YES"

Black screen again on start. What am I missing?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,691
Messages: 39,287

How are you starting Gnome? Are the kernel modules loading correctly (no error messages, etc)? And what do you mean by black screen on start, start of what? Gnome? Or FreeBSD itself?
 
OP
jojopara

jojopara

New Member

Reaction score: 1
Messages: 16

I do not really know how Gnome starts. No idea about the kernel modules, too. When I start FreeBSD in the VM the screen is black. On previous installations, Gnome DE worked all right for a few restarts and then the black screen appeared. After executing the commands you referred to, the problem remains.
 
OP
jojopara

jojopara

New Member

Reaction score: 1
Messages: 16

I know of no way to reach /etc/rx/conf when I have a black screen with nothing working on it.

I used this tutorial -
View: https://www.youtube.com/watch?v=Gr2JCq5AZ5Q
. I am now running FreeBSD in Virtualbox with no issues so far. Perhaps my mistake was that I tried the default setting of RAM and disk space, 1024 and 15 GB respectively. When I changed them to those in the video, I got an operating installation. I noticed, a bit superstitiously, that whenever I turned on bidirectional clipboard and drag and drop, the installation did not work.

My biggest mistake, however, was that I supposed there were no differences as a normal installation and the one in a virtual machine.

Thank you very much for the directions and sorry for your wasted time!
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,691
Messages: 39,287

Perhaps my mistake was that I tried the default setting of RAM and disk space, 1024 and 15 GB respectively.
Disk size is fine and obviously depends on how much you're going to install, I often use 20GB for a typical desktop. But 1024MB of memory is a little on the low side and may be the source of the problems. I'd give it at least 2GB but prefer 4GB or more.

My biggest mistake, however, was that I supposed there were no differences as a normal installation and the one in a virtual machine.
Well, it shouldn't be that much different. You only need the Virtualbox drivers as 'extra', a VM should work and behave just like a "stand-alone" installation running on real hardware.
 
Top