gnome isn't starting after installing it FreeBSD 12.1

Ahmed El Gohary

New Member


Messages: 18

I've installed a fresh copy of FreeBSD 12.1 on a spare HDD, I've followed every single instruction on installing GUI on FreeBSD.
First, I've installed Xorg "pkg install Xorg", followed by installing gnome "pkg install gnome3".
Then I've edited fstab&rc.conf to add proc, and enabled dbus, hald, gdm, and gnome.
After I rebooted the system the GUI didn't start and I'm only able to use SH shell.
 

Attachments

  • 1.jpg
    1.jpg
    30.8 KB · Views: 162
  • 2.jpg
    2.jpg
    33.9 KB · Views: 124
  • 3.jpg
    3.jpg
    89.7 KB · Views: 123
  • 4.jpg
    4.jpg
    43.7 KB · Views: 130

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,607
Messages: 36,269

Install misc/pastebinit, run cat /var/log/Xorg.0.log | pastebinit and post the URL here.
 

eternal_noob

Well-Known Member

Reaction score: 180
Messages: 339

Hi,

have a look at /var/log/Xorg.0.log to see what's going on.

Edit: SirDice beat me to it.
 

eternal_noob

Well-Known Member

Reaction score: 180
Messages: 339

If you have an Intel or AMD graphics card, you need to install graphics/drm-kmod (and load it in rc.conf). Do you do this? I can't see anything like this in your rc.conf.

You have to add your username to the video group too. Did you?
pw groupmod video -m <username>
 

Sevendogsbsd

Daemon

Reaction score: 603
Messages: 1,054

Did you install a display manager as well or were you expecting to start gnome via startx?
 

JAGS2711

New Member


Messages: 1

[SOLVED!!!]

Good morning, everyone...

I am also a newcomer to FreeBSD, and I am trying to learn about it. I have very little experience with FOSS, mostly with Ubuntu.

I have the same problem as the OP, and I am running the distro on a Dell PowerEdge T30 home server, with a Xeon E3-1225 version 5.

To make matters worse, my monitor (a Samsung smart TV) displays the terminal but the first 4 or 5 characters of each line are missing, so navigating or editing a file is a pain in the neck.

I hope a more experienced person can take a look at the attached file and tell me what I did wrong or what I am doing wrong.

UPDATE:

Today, Sunday April 19th, at around 2:30 am I decided to get on this and after nearly 14 hours of research, trial, error, I finally got it
figured out. There are a lot of things not working right now, like network printing and other things, but I am more confident I will get it resolved eventually...
 
Last edited:

rbrick49

Member

Reaction score: 10
Messages: 47

to /boot/loader.conf try adding this hw.syscons.disable=1 it worked for me on kde if it doesnt work you can remove it
 

Zvoni

Active Member

Reaction score: 54
Messages: 128

to /boot/loader.conf try adding this hw.syscons.disable=1 it worked for me on kde if it doesnt work you can remove it
AFAIK, that's only needed if you have an AMD-GPU
That was the Problem on my Ideapad
 
Top