Solved Gnome 42

I installed Gnome 42; startx didn't start it after spewing out a whole bunch of errors. In my /etc/rc.conf I had:
gnome_enable="YES"
gdm_enable="YES"
hald_enable="YES" which I commented out after learning that hald no longer exists
dbus_enable="YES"

It seemed that there was no dbus script in /etc/rc.d. I found one in /usr/local/etc/rc.d and and copied it over to /etc/rc.d which did not solve the problem. When examining the dbus script I saw that the second line had {gnome_enable-NO}; I changed it to YES; rebooted and Gnome 42 worked. I still have to start it using startx because there doesn't seem to be any way to start it with gdm. I commented out all the above entries in /etc/rc.conf and I now have a shiny Gnome 42 as my desktop.
 

SirDice

Administrator
Staff member
Administrator
Moderator
Test and configure Xorg first. Only when that starts without issue should you enable additional DEs or WMs. Make sure your foundation is solid before building the house on top of it.


When examining the dbus script I saw that the second line had {gnome_enable-NO}; I changed it to YES;
Do not edit the rc(8) scripts. That line is supposed to be there. It makes sure it's disabled if you don't have dbus_enable="YES" in /etc/rc.conf. It's supposed to say NO there.
 
Thank you Sir Dice,
I was previously using xfce4, so my Xorg configuration is fine.
Following your advice, I changed the YES to N in /etc/rc.d/dbus. I alse enabled dbus in /etc/rc.conf; Gnome 42 works.
 
To mention, you don't need to move from /usr/local/etc/rc.d to /etc/rc.d. If you activate a service via /etc/rc.conf, the system itself will search both location for the rc files to run the service.
 
My last post was pre-mature. After re-booting Gnome didn't start. So I reverted to the settings in my first post. I know I may have committed a cardinal sin but as a newbie this is the only way I can start Gnome. When I get more familiar with FreeBSD I hope I may find a proper solution. Sorry Sir Dice
 
Here is a screenshot...
 

Attachments

  • gnome_42_Screenshot.png
    gnome_42_Screenshot.png
    581.3 KB · Views: 152
Top