GNOME 3 Fails to launch at boot up

Kartik Javali

New Member


Messages: 7

#1
Hi,

I am using FreeBSD RELEASE 10.1 on i5 target machine.

I installed x11/xorg, which went smooth. I installed x11/gnome3, that also ran successfully. After that I made the recommended changes to /etc/rc.conf. So when I rebooted, I was expecting gnome login to show-up, but instead it takes me to regular command line with root login. I also made edits to ~/.xinitrc and called startx, it shows a blank screen.

Am I missing anything? please help!

Thanks,
 

hukadan

Active Member

Thanks: 153
Messages: 244

#2
Hi,

We need some information here. Could you show us your /etc/rc.conf,/var/log/Xorg.0.log ( cat /var/log/Xorg.0.log | egrep "EE|WW" should do it), ~/.xinitrc and, if you have one, your xorg.conf. It could also be useful to know about your GPU. You can have information using dmesg| grep vga.

Also, do not put similar posts on different threads, it does not help much.
 
OP
OP
K

Kartik Javali

New Member


Messages: 7

#3
Hi,
Sorry for starting new thread, I wasn't sure..

Contents of .xinitrc
Code:
exec gnome-session
Contents of /etc/rc.conf
Code:
hostname="test"
keymap="us.iso.kbd"
ifconfig_fxp0="DHCP"
sshd_enable="YES"
moused_enable="YES"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"
lpd_enable="YES"
hald_enable="YES"
dbus_enable="YES"
slim_enable="YES"
gdm_enable="YES"
gnome_enable="YES"
sendmail_submit_enable="NO"
sendmail_outbound_enable="NO"
sendmail_msp_queue_enable="NO"
contents of /var/log/Xorg.0.log
Code:
[104283.926] (EE) Problem parsing the config file
[104283.926] (EE) Error parsing the config file
[104283.926] (EE)
[104283.926] (EE) no screens found(EE)
[104283.926] (EE)
[104283.927] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[104283.927] (EE)
[104283.927] (EE) Server terminated with error (1). Closing log file.
contents of xorg.conf
Code:
Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        Screen      1  "Screen1" RightOf "Screen0"
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        ModulePath   "/usr/local/lib/xorg/modules"
        FontPath     "/usr/local/lib/X11/fonts/misc/"
        FontPath     "/usr/local/lib/X11/fonts/TTF/"
        FontPath     "/usr/local/lib/X11/fonts/OTF/"
        FontPath     "/usr/local/lib/X11/fonts/Type1/"
        FontPath     "/usr/local/lib/X11/fonts/100dpi/"
        FontPath     "/usr/local/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
        Load  "glx"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/sysmouse"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection

Section "Monitor"
        Identifier   "Monitor1"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"                  # [<bool>]
        #Option     "DefaultRefresh"            # [<bool>]
        #Option     "ModeSetClearScreen"        # [<bool>]
        Identifier  "Card1"
        Driver      "vesa"
        BusID       "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
Section "Screen"
        Identifier "Screen1"
        Device     "Card1"
        Monitor    "Monitor1"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
FontPath "/usr/local/lib/X11/fonts/URW/"
finally here is VGA info

Code:
vgapci0: <VGA-compatible display> mem 0xde000000-0xdeffffff,0xd0000000-0xd7ffffff irq 16 at device 0.0 on pci1
vgapci0: Boot video device
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
vgapci0: <VGA-compatible display> mem 0xde000000-0xdeffffff,0xd0000000-0xd7ffffff irq 16 at device 0.0 on pci1
vgapci0: Boot video device
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
vgapci0: <VGA-compatible display> mem 0xde000000-0xdeffffff,0xd0000000-0xd7ffffff irq 16 at device 0.0 on pci1
vgapci0: Boot video device
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
vgapci0: <VGA-compatible display> mem 0xde000000-0xdeffffff,0xd0000000-0xd7ffffff irq 16 at device 0.0 on pci1
vgapci0: Boot video device
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Thanks for your help!
 

Beeblebrox

Aspiring Daemon

Thanks: 146
Messages: 985

#4
Make sure dbus has actually started. Currently there's a problem with dbus starting via rc(8)(), and you may have that problem as well. Login to tty* and check if dbus is running. If not, start it manually.
# sockstat | grep dbus
# service dbus onestart
# service gdm onestart
 

hukadan

Active Member

Thanks: 153
Messages: 244

#5
I think before configuring any GNOME related things, we should make sure X works, which obviously is not the case given your log.

First, delete your .xinitrc. Then, in your /etc/rc.conf file, comment the following lines :
Code:
hald_enable="YES"
slim_enable="YES"
gdm_enable="YES"
gnome_enable="YES"
By the way, you should choose between x11/slim and x11/gdm which are two different display managers. There is no reason to have both of them and you will for sure run into troubles. If you intend to run GNOME, chosing x11/gdm makes more sense to me.

Then remove your xorg.conf file (or change its name if you want to keep it). As you can see, this latter is not loaded properly and I think the parsing error comes from the last line which has nothing to do in this part of the file. Moreover, it is advised to try the startx command without any xorg.conf file first (see Quick Start section of the Handbook but forget the hald_enable=YES part).

Once you have done all these steps, reboot and once logged, launch startx.

If this does not work, provide your log in your next post.
 
OP
OP
K

Kartik Javali

New Member


Messages: 7

#6
Hi,

I deleted .xinitrc
I edited /etc/rc.conf as suggested above.
I renamed /etc/X11/xorg.conf to /etc/X11/xorg1.conf
Then, I rebooted the machine.
Then, I typed the command # startx
It gave some xauth error "xauth: file /root/.serverauth.749 does not exist" after that it provided a sort of desktop with two windows open one was named login and other xterm and little clock on right top corner.

Here is the log from /var/log/Xorg.0.log
Code:
[   247.022] Initializing built-in extension MIT-SCREEN-SAVER
[   247.171] (WW) Warning, couldn't open module fbdev
[   247.171] (EE) Failed to load module "fbdev" (module does not exist, 0)
[   247.190] (WW) Falling back to old probe method for vesa
[   247.190] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[   247.319] (WW) Warning, couldn't open module xaa
[   247.320] (EE) NV: Failed to load module "xaa" (module does not exist, 0)
[   247.803] (EE) AIGLX error: dlopen of /usr/local/lib/dri/swrast_dri.so failed (Shared object "libexpat.so.1" not found, required by "swrast_dri.so")
[   247.803] (EE) GLX: could not load software renderer
 
OP
OP
K

Kartik Javali

New Member


Messages: 7

#7
Make sure dbus has actually started. Currently there's a problem with dbus starting via rc(8)(), and you may have that problem as well. Login to tty* and check if dbus is running. If not, start it manually.
# sockstat | grep dbus
# service dbus onestart
# service gdm onestart
yes, it says dbus is already running!
 

hukadan

Active Member

Thanks: 153
Messages: 244

#8
Hi,
[ 247.171] (WW) Warning, couldn't open module fbdev
[ 247.171] (EE) Failed to load module "fbdev" (module does not exist, 0)
See if installing x11-drivers/xf86-video-fbdev with pkg install x11-drivers/xf86-video-fbdev fixes the problem. I won't be here to see the result before going back from the pub so I hope it helps to solve the problem ;).
 

hukadan

Active Member

Thanks: 153
Messages: 244

#9
Hi,
it provided a sort of desktop with two windows open one was named login and other xterm and little clock on right top corner.
Assuming that installing x11-drivers/xf86-video-fbdev solved the fbdev module issue, it seems that X is working. What you have obtained here is twm(1), a minimalist window manager. You should uncomment the following lines and restart your computer.
Code:
hald_enable="YES"
gdm_enable="YES"
gnome_enable="YES"
You should end up on a graphic login screen.

-- Edit --
I do not use GNOME so I am not sure you need
Code:
hald_enable="YES"
.
 

PacketMan

Aspiring Daemon

Thanks: 139
Messages: 873

#10
Still trying to figure this out. And of course my Windows 8 OS finally destroyed itself by doing automatic updates so I am trying to repair that too. Anyhow here is what I am seeing on my box that look like errors. I am currently using startx from root, as that worked on another box with KDM.

I'll pick at this again tomorrow night I hope.

My /etc/rc.conf:
Code:
hald_enable="YES"
dbus_enable="YES"
#gnome_enable="YES"
#gdm_enable="YES"
/var/log/Xorg.0.log:
Code:
[  1949.320] (II) Loading sub module "xaa"
[  1949.320] (II) LoadModule: "xaa"
[  1949.321] (WW) Warning, couldn't open module xaa
[  1949.321] (II) UnloadModule: "xaa"
[  1949.322] (II) Unloading xaa
[  1949.322] (EE) NV: Failed to load module "xaa" (module does not exist, 0)
and
Code:
[  1950.509] (II) config/devd: device /dev/ums0 already opened
[  1954.265] (EE) Segmentation fault at address 0x80df05ce0
[  1954.265] (EE)
Fatal server error:
[  1954.265] (EE) Caught signal 11 (Segmentation fault). Server aborting
[  1954.265] (EE)
[  1954.265] (EE)
Please consult the The X.Org Foundation support
  at http://wiki.x.org
for help.
[  1954.265] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  1954.265] (EE)
[  1954.635] (EE) Server terminated with error (1). Closing log file.
Also this in /var/log/gdm:# more :0-greeter.log
Code:
gnome-session-is-accelerated: llvmpipe detected.

(gnome-settings-daemon:1083): media-keys-plugin-WARNING **: Unable to inhibit keypresses: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.login1 was not provided by any .service files

(gnome-settings-daemon:1083): color-plugin-WARNING **: failed to connect to colord: Error calling StartServiceByName for org.freedesktop.ColorManager: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1

(gnome-settings-daemon:1083): Gvc-WARNING **: Failed to connect context: OK

(gnome-shell:1093): Gvc-WARNING **: Failed to connect context: OK
Gjs-Message: JS LOG: No permission to trigger offline updates: Polkit.Error: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Action org.freedesktop.packagekit.trigger-offline-update is not registered

(gnome-settings-daemon:1083): power-plugin-WARNING **: Unable to inhibit suspend: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.login1 was not provided by any .service files

(gnome-settings-daemon:1083): color-plugin-WARNING **: failed to connect to colord: Error calling StartServiceByName for org.freedesktop.ColorManager: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1
Gjs-Message: JS LOG: GNOME Shell started at Mon Mar 30 2015 10:30:37 GMT-0300 (ADT)
 

PacketMan

Aspiring Daemon

Thanks: 139
Messages: 873

#11
Haven't looked at this anymore. My Windows 8 100% disk usage problem (look it up and read the endless stories) has finally pushed my wife's computer over the edge. So I am trying determine what my next step is, after a reinstall made zero difference. My finger is on the trigger to blow away Windows and install Ubuntu GNOME3. Testing the live version and its really really nice. As soon as I can get it working on one of my FreeBSD machines I will likely try it on her computer too. Hope to get it working soon.
 

PacketMan

Aspiring Daemon

Thanks: 139
Messages: 873

#12
It seems I get a different kind of error message when I try different launch approaches. With my /etc/rc.conf set to this:

Code:
hald_enable="YES"
dbus_enable="YES"
gnome_enable="YES"
gdm_enable="YES"
I now get this error message:
Code:
gdm[2453]: Failed to give slave programs access to the display. Trying to proceed.
gdm-launch-environment][2645]: GLib: Source ID 72 was not found when attempting to remove it
 

PacketMan

Aspiring Daemon

Thanks: 139
Messages: 873

#13
fbdev was complaining but I added that port. xaa, and fbdevhw get my attention now, but can't find any solutions through web searching, see attached log. I'll keep trying later.

Note I have run xfce4 and kde4 on this box just fine without issue as far as I knew. Is it possible that GNOME3 has special video card requirements that maybe this thing doesn't satisfy?
 

Attachments

PacketMan

Aspiring Daemon

Thanks: 139
Messages: 873

#15
Any chance someone can point me in a direction I should be looking? I did a fresh install on another machine, using packages instead of ports, and it looks like I have ended up in the same place. One machine is an Acer, another is Compaq, both are 64-bit machines with 10.1-RELEASE, and both have different flavours of NVIDIA video ports.

Thanks in advance.
 

protocelt

Daemon

Thanks: 406
Messages: 1,253

#16
Any chance someone can point me in a direction I should be looking? I did a fresh install on another machine, using packages instead of ports, and it looks like I have ended up in the same place. One machine is an Acer, another is Compaq, both are 64-bit machines with 10.1-RELEASE, and both have different flavours of NVIDEA video ports.

Thanks in advance.
This is possibly a different issue than what the original poster is having. I think your issue here is not GNOME related at all and instead a graphics driver problem. You seem to be using x11-drivers/xf86-video-nv instead of x11/nvidia-driver. To my knowledge x11-drivers/xf86-video-nv doesn't work with x11/gnome3. Use x11/nvidia-driver instead. You shouldn't need an xorg.conf file at all. If, after swtching to the nvidia-driver you still have a problem, create an xorg.conf file and append only the following to it:
Code:
Section "Device"
    Identifier  "Card0"
    Driver  "nvidia"
EndSection
X.org should take care of the rest automatically. Hopefully this should fix your issue. :)

As a side note and slightly off topic, I am/have been working on writing up a "How To" for configuring Nvidia based FreeBSD desktop systems as I have a lot of different generation Nvidia cards lying around I've collected throughout the years. It's coming along very slow due to time constraints but I should have a lot more time within the next couple of months so I'll be able to focus on it much more.
 

PacketMan

Aspiring Daemon

Thanks: 139
Messages: 873

#17
This is possibly a different issue than what the original poster is having. I think your issue here is not GNOME related at all and instead a graphics driver problem. You seem to be using x11-drivers/xf86-video-nv instead of x11/nvidia-driver. To my knowledge x11-drivers/xf86-video-nv doesn't work with x11/gnome3. Use x11/nvidia-driver instead.
Thanks protocelt. I honestly thought x11-drivers/xf86-video-nv was also a NVIDIA driver. :p I tried that but I can't install the x11/nvidia-driver. It says I needs emulators/linux_base-c6. So when I go to install that it fails telling me that
Code:
linux_base-c6 linuxulator is not (kld)loaded.
Whaaa?:confused: It won't let me install it because its not already running? Is this a dependency loop?

I'll pick at this some more this week. This looks like a good place to start: Thread freebsd-and-linux-emulator-problem.10260

Thanks again protocelt.
 

protocelt

Daemon

Thanks: 406
Messages: 1,253

#19
Thanks protocelt. I honestly thought x11-drivers/xf86-video-nv was also a nvidia driver. :p
It is but as far as I understand is deprecated and hasn't been actively maintained at all for quite some time. On top of that it doesn't offer any 3D acceleration from what I understand which is I think required by GNOME. I think some people still use it for very old hardware but I don't know much about that.
 

protocelt

Daemon

Thanks: 406
Messages: 1,253

#21
Just configure the build options before attempting to install the ports.
  1. # cd /usr/ports/x11/nvidia-driver
  2. # make config (to configure your build options)
  3. # make install (install the port)
 

PacketMan

Aspiring Daemon

Thanks: 139
Messages: 873

#22
Thanks a bunch protocelt. So much to learn, so little time.

So did that, and now I get a white screen with a sad face saying something gone wrong, cannot recover. So now I will pick at this. :)
 
Last edited by a moderator:

PacketMan

Aspiring Daemon

Thanks: 139
Messages: 873

#23
So I saw in /var/log/messages:
Code:
Apr  9 19:38:55 Freedom-C001 kernel: NVRM: The NVIDIA GeForce 6100 nForce 405 GPU installed in this system is
Apr  9 19:38:55 Freedom-C001 kernel: NVRM:  supported through the NVIDIA 304.xx Legacy drivers. Please
Apr  9 19:38:55 Freedom-C001 kernel: NVRM:  visit http://www.nvidia.com/object/unix.html for more
Apr  9 19:38:55 Freedom-C001 kernel: NVRM:  information.  The 346.47 NVIDIA driver will ignore
Apr  9 19:38:55 Freedom-C001 kernel: NVRM:  this GPU.  Continuing probe...
So I removed x11/nvidia-driver and installed x11/nvidia-driver-304. I don't see that message anymore. But I do see:
Code:
Apr  9 21:37:44 Freedom-C001 dbus[606]: [system] Activating service name='org.freedesktop.ConsoleKit' (using servicehelper)
Apr  9 21:37:44 Freedom-C001 dbus[606]: [system] Activating service name='org.freedesktop.PolicyKit1' (using servicehelper)
Apr  9 21:37:45 Freedom-C001 dbus[606]: [system] Successfully activated service 'org.freedesktop.PolicyKit1'
Apr  9 21:37:45 Freedom-C001 dbus[606]: [system] Successfully activated service 'org.freedesktop.ConsoleKit'
Apr  9 21:37:45 Freedom-C001 console-kit-daemon[632]: WARNING: kvm_getenvv failed:
Apr  9 21:37:45 Freedom-C001 ntpd[670]: ntpd 4.2.4p5-a (1)
Apr  9 21:37:45 Freedom-C001 avahi-daemon[701]: WARNING: No NSS support for mDNS detected, consider installing nss-mdns!
Apr  9 21:37:51 Freedom-C001 dbus[606]: [system] Activating service name='org.freedesktop.Accounts' (using servicehelper)
Apr  9 21:37:51 Freedom-C001 dbus[606]: [system] Successfully activated service 'org.freedesktop.Accounts'
Apr  9 21:37:54 Freedom-C001 console-kit-daemon[632]: WARNING: Error waiting for native console 1 activation: Device not configured
Apr  9 21:37:53 Freedom-C001 ntpd[671]: time reset -0.678470 s
Apr  9 21:37:55 Freedom-C001 gdm[692]: Failed to give slave programs access to the display. Trying to proceed.
And in /var/log/Xorg.0.log I do see:
Code:
[  29.727] (EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)
Time for bed. Will pick at this soon I hope.
 

protocelt

Daemon

Thanks: 406
Messages: 1,253

#24
Ok now were getting further. :) Are you using x11/gdm to log into GNOME or starting your Xsession from the command line using startx(1)? It looks like sysutils/consolekit isn't being started which is required for x11/gnome-shell to function I think. It should be started automatically if your using gdm. If your using startx(1), you'll need to add the following to your ~/.xinitrc file:
Code:
exec ck-launch-session dbus-launch --exit-with-session /usr/local/bin/gnome-session
instead of just
Code:
exec /usr/local/bin/gnome-session
before running startx. Hopefully this helps.
 

PacketMan

Aspiring Daemon

Thanks: 139
Messages: 873

#25
Ok now were getting further. :) Are you using x11/gdm to log into GNOME or starting your Xsession from the command line using startx(1)?
I am not using startx. Here is my current config at this moment in time:

/boot/loader.conf
Code:
nvidia_load="YES"
linux_enable="YES"
/etc/rc.conf
Code:
dumpdev="AUTO"
hald_enable="YES"
dbus_enable="YES"
#linux_enable="YES"
#nvidia_enable="YES"
gdm_enable="YES"
gnome_enable="YES"
/root/.xinitrc does not exist, nor does either of these:

/etc/X11/xorg.conf
/usr/local/etc/X11/xorg.conf


I had dbus and hald disabled but noticed during bootup the OS was complaining that dbus startup settings was not configured correctly. Moved the Linux and NVIDIA options over to the loader after I saw it made no difference in rc.conf.
 
Last edited by a moderator:
Top