Gitlab-Runner makes a Gitlab 502 after install

Hi Community,

Yes, I am new in FreeBSD and I find a lots of "errors"? I installed the GitLab from ports tree and it works fine. My next try was: Install Gitlab-Runner. First, I installed the runner with instructions from GitLab directly. I get an error. Timetravel to the Point before I try install and try again with gitlab-runner from ports tree. After install, I get the same error:

My GitLab shows me "502 Whoops! Gitlab is taking to much time to respond." ...

I try to restart Gitlab (service gitlab restart) and get an Error with Unicorn, that Unicorn is not running. I searched a lot but only found "Do a reconfi with gitlabg-ctl reconfigure" ... It does not work with FreeBSD.

Did anyone has the same problem?

I installed gitlab runner and gitlab in the same jail.
Stopping gitlab-runner doesn't fix it.

Thanks a lot for your help! :)
  • Thanks
Reactions: Oko
Hi eqvvs,

Any luck with your installation?

I'm also trying installing gitlab, but from pkg. Haven't found any luck.

I wonder if the community has given up on gitlab?

Best Regards,
I run Gogs (GitHub clone written in Go) in production even though it is not in the ports. Gitea a Gogs fork is in ports but it is unclear who is winning on the long run. You can find my obsolete Gogs how to on this forum.

I waisted a week of my life trying to get GitLab working before it was even in the ports. It is super complicated and setting it up can make grown up man cry. Probably the easiest way is using Linux TurnKey appliance

Linux guys mostly use Docker to ease the pain but GitLab is one of those applications only worth setting up for a very large organization with dedicated resources (both Ruby developers and hardware). Gogs on the another hand appeals to small to medium teams.