Solved Getting X to work with NVidia/Intel configuration

Babilomax

New Member

Reaction score: 1
Messages: 3

Hi everyone,

After having read many threads about problems similar to mine, I still have not found a solution that worked for me; so I will try and describe my situation.

I am new to FreeBSD (coming from Linux) and decided to install it on my ASUS X43SD (2012 laptop). Everything was going fine until I wanted to install the GUI.

First odd thing, it seems that I have two GPUs :

Code:
# lspci  | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [GeForce 610M] (rev a1)
Is this a usual configuration that I'm not familiar with?
Anyway, after installing X.org, the simple command startx (with hald and dbus enabled and running) doesn't work. I get the error "no screens found" (log: http://pastebin.com/3wvLr1Eg).

So I tried Xorg -configure. But first of all, it froze my laptop (screen turned black and I could not go back to the console; the only controls I could were Ctrl+Alt+Del to reboot and the power button to shut down). It created the /root/xorg.conf.new file though, but what was in it does not seem to make sense, like I have 6 monitors.
Here is the xorg.conf.new file: http://pastebin.com/YvVwAH3c
And the subsequent log: http://pastebin.com/XFSkzD4D

In both logs, there seems to be a problem with the module fbdevhw. I have installed the drivers x11-drivers/xf86-video-fbdev, x11/nvidia-driver and x11-drivers/xf86-video-intel, still getting the same results.

At that point, I tried to manually edit the xorg.conf: I left only one monitor, and one driver, the nvidia one. Here is the modified xorg.conf.new: http://pastebin.com/zXSx9trP
Then the result of startx was more interesting. The error "no screens found" is gone, but basically nothing happens, the console cursor disappears. This time though, I was able to go back to the console hitting Ctrl+Alt+F1. The log file seems to state that everything is OK: http://pastebin.com/dJVBmQH6

Only I don't really agree, since nothing works.
That's it, sorry about the long, boring description. If you have any idea that could help me with this mess, I would greatly appreciate.

Thanks in advance.
 

wblock@

Beastie Himself
Developer

Reaction score: 3,649
Messages: 13,850

You have several different problems interacting.

First, Optimus. This is not presently supported on FreeBSD. Some people have success with disabling the Nvidia GPU in the BIOS and just using the Intel GPU. Sometimes that is not an option. I'm told that Nvidia supports FreeBSD, but they do not support Optimus.

The problem of the console not being visible after leaving X is often due to still using the old sc(4) driver for the console rather than the new vt(4). To use vt(4), add a line to /boot/loader.conf:
Code:
kern.vty=vt
 
OP
OP
B

Babilomax

New Member

Reaction score: 1
Messages: 3

Thank you. Using vt(4) makes the console use a smaller police, and I am now able to switch back to the console while X is running.
In addition, I noticed that when running Xorg -config xorg.conf.new -retro, I do get the expected grey and black grid, but the mouse does not work yet.

Unfortunately, my Nvidia GPU can't be disabled in the BIOS. Does that mean I'll never have any graphics? I don't understand X producing a normal-looking log file when in fact it is not working.
 

wblock@

Beastie Himself
Developer

Reaction score: 3,649
Messages: 13,850

Last edited:
OP
OP
B

Babilomax

New Member

Reaction score: 1
Messages: 3

Problem solved!
I was finally able to get X working by simply keeping only one "device" section, setting the driver to "intel" with the appropriate PCI identifier and removing all the useless stuff : http://pastebin.com/Kxw8J8CR

I don't know why I hadn't tried that sooner. I guess this way my Nvidia GPU is useless, but it's not really a problem since I don't intend to run complex graphics.
Thank you wblock@ for your help!
 
Top