Solved Geli passphrase prompt and keyboard layout

Fuzzbox

Member

Reaction score: 108
Messages: 62

Hi,

I'm experimenting with geli encryption on a spare laptop.
I've activated ZFS root encryption from the FreeBSD installer.

I'm using a french keyboard layout.
After POST, Geli prompts me for the passphrase with a US keyboard layout. That's annoying.

I've set the geom_eli_passphrase_prompt="YES" option.
Now the boot loader prompts me for the passphrase too, with the expected Azerty keyboard layout.

Is there a way to get rid of the first passphrase prompt ??
 

T-Daemon

Daemon

Reaction score: 883
Messages: 1,762

I've set the geom_eli_passphrase_prompt="YES" option.
That setting has no effect on the geli passphrase at all, at least not on 13.0-RELEASE. Just press 'Enter' or type in any keys, press 'Enter' and it's unlocked.

Is there a way to get rid of the first passphrase prompt ??
That's not possible. That (real) passphrase is bound to the encrypted root partition (don't get mislead by the loader.conf setting).

As I see it you have two options:

1 - Set a new passphrase for the encrypted root partition, change before entering it to us keyboard layout, i.e.
Code:
# kbdcontrol -l us
# geli setkey /dev/ada0p3

Passphrase typed in after FR keyboard layout
wqazertym

in reality US
zaqwerty:

# kbdcontrol -l fr

2 - Build a custom kernel, description here.
 
Top