GDM wont start

alie

Aspiring Daemon

Reaction score: 54
Messages: 575

I installed gnome2.24.

When ever I restart gdm I get the following.

** (gdm-binary:2646): WARNING **: Couldn't connect to system bus: Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory

anyone have clue ?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 8,970
Messages: 33,431

Make sure dbus and hal are running.

In /etc/rc.conf:
Code:
dbus_enable="YES"
hald_enable="YES"
 
OP
alie

alie

Aspiring Daemon

Reaction score: 54
Messages: 575

@niko: what is that for ? can u explain.
 

crsd

Well-Known Member

Reaction score: 94
Messages: 419

SirDice said:
Make sure dbus and hal are running.

In /etc/rc.conf:
Code:
dbus_enable="YES"
hald_enable="YES"
Or you can enable all GNOME-related services with gnome_enable="YES" in /etc/rc.conf (it's in FAQ, BTW :) )
 

ericturgeon

Well-Known Member

Reaction score: 65
Messages: 367

ok i run freebsd whit gnome 2.24 gdm 2.20 and gnome-applets 2.22 and it work good. gdm 2.22 and 2.24 is not perfect but all linux, bsd or opensolaris use
gdm 2.20 i work on a gnome BSD release bas on freebsd opensolaris and ubuntu linux.

to add gdm2.20 just remove gdm
and reinstall whit

pkg_add -r gdm

it just install the default package of gdm2.20.
 
OP
alie

alie

Aspiring Daemon

Reaction score: 54
Messages: 575

it wont start.. with this error:

gdm-binary[1223]: WARNING: GdmDisplay: display laster 2.18324791 seconds
gdm-binary[1223]: WARNING: GdmDisplay: display laster 2.12312312 seconds
gdm-binary[1223]: WARNING: GdmDisplay: display laster 2.67556732 seconds
gdm-binary[1223]: WARNING: GdmDisplay: display laster 2.32432423 seconds
gdm-binary[1223]: WARNING: GdmDisplay: display laster 2.13244441 seconds
gdm-binary[1223]: WARNING: GdmLocalDisplayFactory: maximum number of X display failures reached: check x server log for errors.
 

nikobordx

Active Member

Reaction score: 5
Messages: 107

Hi Alie,

If i don't mount proc, gdm does not match my user name and i cannot connect to gnome (and it's needed for hal to automount devices).
Gdm 2.24 is "relatively" bad (and uggly) compared to 2.20 !
So just add this to your fstab !

Niko.
 

mickey

Aspiring Daemon

Reaction score: 150
Messages: 528

nikobordx said:
Gdm 2.24 is "relatively" bad (and uggly) compared to 2.20 !
... to put it mildly. GDM 2.24 is a half-baked farce.
 

zeiz

Aspiring Daemon

Reaction score: 57
Messages: 691

nikobordx meant that you should put the line mentioned in fstab file; location: /etc/fstab
# ee /etc/fstab
You should see some entries for your partitions and cdrom. Add the line like this:

Code:
file system  mount point   type    options     dump    pass
proc            /proc      procfs     rw         0       0
Press Esc then "a" and "a" again.
 
OP
alie

alie

Aspiring Daemon

Reaction score: 54
Messages: 575

@nikobordx: its not working at all(see post #7)... i uninstalled both gnome2.24 and GDM2.24... i am using openbox with XDM now :)
 
OP
alie

alie

Aspiring Daemon

Reaction score: 54
Messages: 575

7.1-STABLE with xorg7.3 and i got gnome2.24 from gnome tinderbox (MarcusCom)
 

nikobordx

Active Member

Reaction score: 5
Messages: 107

ok Alie, i think you need to update xorg to version 7.4, after reinstall gnome and it should be working !
 

thavinci

Member


Messages: 78

Yeh this is an issue with Compiling gnome from ports at the moment, i have EXACT same issue, upgraded my ports via cvsup before starting the attempt and even went as far to upgrade ALL components via portupgrade -af.

So issues....
 
OP
alie

alie

Aspiring Daemon

Reaction score: 54
Messages: 575

@thavinci: yup... i've tried installed FreeBSD, xorg and gnome2.24 from scratch and still got same problem with gnome tinderbox. here's my steps:
1) install FreeBSD 7.1-STABLE/RELEASE with minimal installation
2) do portsnap fetch && extract
3) make install clean xorg or xorg-minimal
4) configure my xorg and test with startx (everything is ok from this step)
5) change the PACKAGESITE to marcuscom gnome tinderbox
6) pkg_add -r gnome2
7) add hald_enable="YES" and dbus_enable="YES"
8) add proc /proc procfs rw 0 0 to fstab
9) restart to make sure everything is ok
10) GDM <--- got the problem!
 

ericturgeon

Well-Known Member

Reaction score: 65
Messages: 367

like i said gdm 2.24 is broken i try all i can for resolve this problem boot nothig to do and some i you chek in the freebsd gnome 2.22 come Whit gdm 2.20!!!
and some linux programer have the same probleme you need to install gdm 2.20 not gdm 2.24.
 

DrJ

Well-Known Member

Reaction score: 46
Messages: 308

alie said:
5) change the PACKAGESITE to marcuscom gnome tinderbox
6) pkg_add -r gnome2
7) add hald_enable="YES" and dbus_enable="YES"
8) add proc /proc procfs rw 0 0 to fstab
Those are not all of the daemons required for Gnome. There are five: dbus, avahi_daeamon, avahi_dnsconf, hal, and gdm, all of which must be started. gdm further starts a session with ConsoleKit, which is required for access to certain Gnome menu items requiring superuser access.

It is easier just to use gnome_enable="YES" in rc.conf. That gets them all in one shot.
 
OP
alie

alie

Aspiring Daemon

Reaction score: 54
Messages: 575

i've a problem if i plug in my external DVD/CD-ROM Drive with hald_enable or gnome_enable, FreeBSD will throws an error "Atapi not supported bla bla"
 

DrJ

Well-Known Member

Reaction score: 46
Messages: 308

That's a different issue (which sounds like HAL set-up, and more likely, your /etc/devfs.conf, /etc/devfs.rules or both). I'd suggest you get Gnome working first, more or less, and then tend to that issue.
 

Kariddi

New Member


Messages: 4

Hi , I've installed XFCE on my system and I'd like to use GDM as Desktop Manager to load XFCE.

GDM is installed as a dependency of the XFCE port.

I've enabled dbus, hald and gdm in rc.conf.

The problem is that when GDM starts all I get is a black screen with the mouse cursor in the center of the screen (i can move the mouse cursor). I can switch back to any text console with CTRL+ALT+FX , but GDM just remains black.

I can start XFCE successfully with startx, so it doesn't seem to be a X problem.

Any suggestion?
 

Recruit0

New Member


Messages: 1

Kariddi said:
The problem is that when GDM starts all I get is a black screen with the mouse cursor in the center of the screen (i can move the mouse cursor).
Had same problem. I couldn't find answer anywhere. Saw gnome-session mentioned a few times and gave it a shot. Seems to be the problem. You have to install gnome-session manually even though it should be a dependency:

pkg_add -r gnome-session

Hopefully will work for you too.
 
Top