gam_server gone mad!

freemason

Member


Messages: 64

It is going to use 100% cpu when browsing filesystem in gtk apps (firefox, etc.).

After some "googling" I create file ~/.gaminrc:
Code:
fsset ufs poll 3
and then gamin calms down :e.

But why aren't there any notices (or warnings) when installing this port?
Maybe port should provide some example gaminrc?

Thanks.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,562
Messages: 30,279

freemason said:
But why aren't there any notices (or warnings) when installing this port?
There are.

Code:
dice@vps-2417-1:~>cd /usr/ports/devel/gamin/
dice@vps-2417-1:/usr/ports/devel/gamin>cat pkg-message
===============================================================================

Gamin will only provide realtime notification of changes for at most n files,
where n is the minimum value between (kern.maxfiles * 0.7) and
(kern.maxfilesperproc - 200). Beyond that limit, files will be polled.

If you often open several large folders with Nautilus, you might want to
increase the kern.maxfiles tunable (you do not need to set
kern.maxfilesperproc, since it is computed at boot time from kern.maxfiles).

For a typical desktop, add the following line to /boot/loader.conf, then
reboot the system:

    kern.maxfiles="25000"

The behavior of gamin can be controlled via the various gaminrc files.
See http://www.gnome.org/~veillard/gamin/config.html on how to create
these files.  In particular, if you find gam_server is taking up too much
CPU time polling for changes, something like the following may help
in one of the gaminrc files:

# reduce polling frequency to once per 10 seconds
# for UFS file systems in order to lower CPU load
fsset ufs poll 10

===============================================================================
 

teo

Well-Known Member

Reaction score: 11
Messages: 475

There are.

Code:
dice@vps-2417-1:~>cd /usr/ports/devel/gamin/
dice@vps-2417-1:/usr/ports/devel/gamin>cat pkg-message
===============================================================================

Gamin will only provide realtime notification of changes for at most n files,
where n is the minimum value between (kern.maxfiles * 0.7) and
(kern.maxfilesperproc - 200). Beyond that limit, files will be polled.

If you often open several large folders with Nautilus, you might want to
increase the kern.maxfiles tunable (you do not need to set
kern.maxfilesperproc, since it is computed at boot time from kern.maxfiles).

For a typical desktop, add the following line to /boot/loader.conf, then
reboot the system:

    kern.maxfiles="25000"

The behavior of gamin can be controlled via the various gaminrc files.
See http://www.gnome.org/~veillard/gamin/config.html on how to create
these files.  In particular, if you find gam_server is taking up too much
CPU time polling for changes, something like the following may help
in one of the gaminrc files:

# reduce polling frequency to once per 10 seconds
# for UFS file systems in order to lower CPU load
fsset ufs poll 10

===============================================================================
What am I supposed to do with that message?

# pkg install thunar-vfs fuse fuse-utils
Code:
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
The following 11 package(s) will be affected (of 0 checked)
................         ..........        ..............
................         ..........        ..............
[7/11] Installing gamin-0.1.10_10...
[7/11] Extracting gamin-0.1.10_10: 100%
[8/11] Installing libspectrum-1.4.4...
[8/11] Extracting libspectrum-1.4.4: 100%
[9/11] Installing thunar-vfs-1.2.0_12...
[9/11] Extracting thunar-vfs-1.2.0_12: 100%
[10/11] Installing fuse-1.5.7...
[10/11] Extracting fuse-1.5.7: 100%
[11/11] Installing fuse-utils-1.4.3...
[11/11] Extracting fuse-utils-1.4.3: 100%
Message from gamin-0.1.10_10:

===============================================================================

Gamin will only provide realtime notification of changes for at most n files,
where n is the minimum value between (kern.maxfiles * 0.7) and
(kern.maxfilesperproc - 200). Beyond that limit, files will be polled.

If you often open several large folders with Nautilus, you might want to
increase the kern.maxfiles tunable (you do not need to set
kern.maxfilesperproc, since it is computed at boot time from kern.maxfiles).

The behavior of gamin can be controlled via the various gaminrc files.
See http://www.gnome.org/~veillard/gamin/config.html on how to create
these files. In particular, if you find gam_server is taking up too much
CPU time polling for changes, something like the following may help
in one of the gaminrc files:

# reduce polling frequency to once per 10 seconds
# for UFS file systems in order to lower CPU load
fsset ufs poll 10

===============================================================================
===> NOTICE:

The gamin port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
#
 

Stazer

New Member


Messages: 4

What am I supposed to do with that message?

# pkg install thunar-vfs fuse fuse-utils
Code:
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
The following 11 package(s) will be affected (of 0 checked)
................         ..........        ..............
................         ..........        ..............
[7/11] Installing gamin-0.1.10_10...
[7/11] Extracting gamin-0.1.10_10: 100%
[8/11] Installing libspectrum-1.4.4...
[8/11] Extracting libspectrum-1.4.4: 100%
[9/11] Installing thunar-vfs-1.2.0_12...
[9/11] Extracting thunar-vfs-1.2.0_12: 100%
[10/11] Installing fuse-1.5.7...
[10/11] Extracting fuse-1.5.7: 100%
[11/11] Installing fuse-utils-1.4.3...
[11/11] Extracting fuse-utils-1.4.3: 100%
Message from gamin-0.1.10_10:

===============================================================================

Gamin will only provide realtime notification of changes for at most n files,
where n is the minimum value between (kern.maxfiles * 0.7) and
(kern.maxfilesperproc - 200). Beyond that limit, files will be polled.

If you often open several large folders with Nautilus, you might want to
increase the kern.maxfiles tunable (you do not need to set
kern.maxfilesperproc, since it is computed at boot time from kern.maxfiles).

The behavior of gamin can be controlled via the various gaminrc files.
See http://www.gnome.org/~veillard/gamin/config.html on how to create
these files. In particular, if you find gam_server is taking up too much
CPU time polling for changes, something like the following may help
in one of the gaminrc files:

# reduce polling frequency to once per 10 seconds
# for UFS file systems in order to lower CPU load
fsset ufs poll 10

===============================================================================
===> NOTICE:

The gamin port currently does not have a maintainer. As a result, it is
more likely to have unresolved issues, not be up-to-date, or even be removed in
the future. To volunteer to maintain this port, please create an issue at:

https://bugs.freebsd.org/bugzilla

More information about port maintainership is available at:

https://www.freebsd.org/doc/en/articles/contributing/ports-contributing.html#maintain-port
#
It's saying that you need to add kern.maxfiles="25000" to /boot/loader.conf. Simply open your terminal with root privileges and enter
Code:
echo 'kern.maxfiles="25000"' >> /boot/loader.conf
Afterwards reboot your system.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,562
Messages: 30,279

That message should probably be removed, these days the default setting of kern.maxfiles is already way larger than the suggested 25000. The actual default value depends on the amount of memory the machine has though.
 

teo

Well-Known Member

Reaction score: 11
Messages: 475

That message should probably be removed, these days the default setting of kern.maxfiles is already way larger than the suggested 25000. The actual default value depends on the amount of memory the machine has though.
Hello SirDice, the actual value of RAM memory base that has the virtualized machine (guest) is 2048 MB, how would you proceed?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,562
Messages: 30,279

Simple, check the value before actually setting it. If it's already higher than 25000 you don't have to do anything.
 

teo

Well-Known Member

Reaction score: 11
Messages: 475

Simple, check the value before actually setting it. If it's already higher than 25000 you don't have to do anything.
And how do I proceed to check the value before adjusting it?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,562
Messages: 30,279

sysctl kern.maxfiles will output the current value.
 

teo

Well-Known Member

Reaction score: 11
Messages: 475

sysctl kern.maxfiles will output the current value.
The output of the consumption in the console as in the graphical desktop and a browser in youtube visualizing video emits the current value.

$ sysctl kern.maxfiles
Code:
kern.maxfiles: 64305
$
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,562
Messages: 30,279

As you can see it's already more than twice as high as the suggested 25000. So there's no need to set it.
 
Top