FSCK: cannot determine filesystem type (6.2->8.2)

monkeyboy

Member

Reaction score: 10
Messages: 99

I converted a FreeBSD 6.2 system to 8.2, with a couple of data drives that supposedly would "move over". However I found that bsdlabel complained about the partitioning of these drives and then fsck reported
Code:
cannot determine filesystem type
Got me a little worried that 8.2 couldn't read these drives/filesystems from 6.2.

As it turns out, running fsck_ffs instead worked fine and the drives mounted okay. I gather that between 6.2 and 8.2, fsck tried to get "smarter" but not smart enough to figure out to use fsck_ffs with these drives. Also the use of the 'c' partition is now (weakly) prohibited.

It would be nice to be able to "restore" 8.2 fsck's ability to realize that these are FFS filesystems. Any clues as to how? (I guess I could read the code to see what it is trying to test.)
 

graudeejs

Son of Beastie

Reaction score: 696
Messages: 4,616

Use the -t flag.

$ fsck -t ufs /dev/da0
(Don't remember if ufs was in lowercase or uppercase, probably lowercase)
 
OP
M

monkeyboy

Member

Reaction score: 10
Messages: 99

Thanks, I get it now, although not sure why dumpfs can figure these things out, but fsck needs to look in fstab when a filesystem may very well not be in there. I guess you could argue the read vs read/write/destroy issue, but presuming that fstab is actually correct doesn't seem much better.
 

tingo

Daemon

Reaction score: 470
Messages: 2,221

Yes, it is a bit annoying that fsck in 8.2 (or perhaps this started in 8.1, I don't remember) can't figure this out on its own, while it did in all previous releases. It could be argued that this change is a POLA violation, too.
 
Top