Fresh install freezes at Network Configuration

Hello everyone, I'm sort of new to using FreeBSD. I tried finding a fix online but I came up with nothing. To give some background, I use a laptop that came preinstalled with Windows 8. I had to format my hard drive but was unable to reinstall windows because I couldn't find my disc anywhere. So I tried installing multiple Linux distros, they all had the same issue of freezing at network configuration, even after I tried multiple fixes online. So then I decided to try FreeBSD, same issue.

*Extra details, the network interface is Qualcomm Atheros AR9565
*The laptop is a Toshiba Sattelite c55-B5201
Last edited by a moderator:
So then I decided to try Freebsd, same issue.
Which version did you try?

Also: when exactly does the freeze happen? How do you get out of it? Is it just a freeze after which you need to power down your laptop or can you still reset it somehow? Also: no kernel messages or anything (kernel panic)?
Try popping the wifi card out, connect with ethernet cable if that is an option. If you can install it successfully, make sure networking at least works with physical cable connection. Pop it back in and give us any messages if it doesn't just hang up like before. If it's fairly new and you don't want to crack it open we understand. You've already formatted the drive so you at least have a toe in the water