[FreeBSD7.1] OpenSSL won't upgrade to newest version

Anyone successfully upgraded OpenSSL on FreeBSD 7.1?

Spent a few days trying to upgrade to 0.9.8j, tried about a dozen of methods, but "openssl version" still shows:
OpenSSL 0.9.8e 23 Feb 2007

the new version ended up in /usr/local/lib and /usr/local/bin
while the base version is at /lib and /usr/bin

Tried installing from source, from port, cvsup'd/portsnaped, deinstalled, maked clean, even hacked makefiles.

Base OpenSSL still shows 0.9.8e.

How did you do it? :(
installing from source using ./config --prefix=/usr and make install clean resulted in:

making install in fips/dsa...
making install in fips/rsa...
making install in fips/dh...
making install in fips/hmac...
cp: fipscanister.o.sha1: No such file or directory
cp: fipscanister.o: No such file or directory
*** Error code 1
ok this did it:

make kern.securelevel=-1 in sysctl.conf if you have changed it before,then:

cd /usr/ports/security/openssl
make deinstall
./config --prefix=/usr
gmake clean
gmake install clean

#ls -l /usr/bin
-r-xr-xr-x 1 root wheel 661584 Jan 1 18:48 objdump
-r-xr-xr-x 3 root wheel 25288 Jan 1 18:49 od
-rwxr-xr-x 1 root wheel 1941310 Jan 11 23:15 openssl
-r-sr-xr-x 1 root wheel 7120 Jan 1 18:49 opieinfo
-r-xr-xr-x 4 root wheel 11664 Jan 1 18:49 opiekey

#openssl version
OpenSSL 0.9.8j 07 Jan 2009